2 Replies Latest reply on Oct 13, 2015 4:44 PM by Richard Lucas

    How to stop Modeshape using Transient Binary Store for large Strings

    Richard Lucas Apprentice

      I'm using Modeshape 4.3 via the Wildfly Modeshape sub-system. I do not have a binary store configured in my sub-system. It looks like when this is the case Modeshape defaults to using a transient binary store.

       

      14:36:20,517 DEBUG [org.modeshape.jcr.JcrRepository] (default task-1) Starting 'example-repo' repository with configuration: 
      { "name" : "example-repo" , "jndiName" : "" , "storage" : { "cacheName" : "example-repo" , "cacheConfiguration" : "modeshape/repo-test-cache-config.xml" , "binaryStorage" : { "type" : "transient" } } .....
      

       

      I am attempting to store a string property on a node that is greater than 4kb, because the string exceeds the default binary min value size, it is being written to the transient binary store instead of directly on the node. This behavior is undesirable as I do not want to store the string in a binary store, and I definitely do not want it to be in a transient store as it does not survive a restart.

       

      Is there a way to configure Modeshape via the Wildfly sub-system to increase the binary min value size used by the transient store?

       

      I currently can not see a way to do this as the transient store is not one of the binary store options in the sub-system XSD.