1 Reply Latest reply on Oct 15, 2015 4:30 PM by Alexey Kazakov

    want to use tern 1.1.0 snapshot with jboss tools 3.7

    nimo stephan Master

      Can I install tern 1.1.0 snapshot without having conflicts with jboss tools 3.7 afterwards?:

       

      Your original request has been modified.

        "Tern feature" is already installed, so an update will be performed instead.

        "minimal-json" is already installed, so an update will be performed instead.

        "Tern server node.js feature" is already installed, so an update will be performed instead.

        "Tern JSDT feature" is already installed, so an update will be performed instead.

        "Tern Linters" is already installed, so an update will be performed instead.

        "minimatch.java" is already installed, so an update will be performed instead.

      Cannot complete the install because of a conflicting dependency.

        Software being installed: Tern server node.js feature 1.1.0.201510151208 (tern-server-nodejs-feature.feature.group 1.1.0.201510151208)

        Software currently installed: JBoss Tools Java Standard Tools Tern.java Adapter 3.7.0.Final-v20150924-2233-B43 (org.jboss.tools.jst.jsdt.feature.feature.group 3.7.0.Final-v20150924-2233-B43)

      Only one of the following can be installed at once:

          Tern Node.js Eclipse - UI 1.1.0.201510151208 (tern.eclipse.ide.server.nodejs.ui 1.1.0.201510151208)

          Tern Node.js Eclipse - UI 1.0.0.201508302102 (tern.eclipse.ide.server.nodejs.ui 1.0.0.201508302102)

      Cannot satisfy dependency:

          From: JBoss Tools Java Standard Tools - Tern Project Adapter 3.7.0.Final-v20150924-2233-B43 (org.jboss.tools.jst.jsdt 3.7.0.Final-v20150924-2233-B43)

          To: bundle tern.eclipse.ide.server.nodejs.ui [1.0.0.201508302102]

        Cannot satisfy dependency:

          From: JBoss Tools Java Standard Tools Tern.java Adapter 3.7.0.Final-v20150924-2233-B43 (org.jboss.tools.jst.jsdt.feature.feature.group 3.7.0.Final-v20150924-2233-B43)

          To: org.jboss.tools.jst.jsdt [3.7.0.Final-v20150924-2233-B43]

      Cannot satisfy dependency:

          From: Tern server node.js feature 1.1.0.201510151208 (tern-server-nodejs-feature.feature.group 1.1.0.201510151208)

          To: tern.eclipse.ide.server.nodejs.ui [1.1.0.201510151208]