2 Replies Latest reply on Oct 19, 2015 1:02 PM by Junior Sousa

    EAP 6.4 - enable-welcome-root as false does not works

    Junior Sousa Newbie


      Hi,

      I added the file jboss-web.xml at WEB-INF directory into war application and also changed the entry enable-welcome-root as false of standalone.xml but the JBoss Welcome Page is still appearing instead of the welcome page I set on web.xml, do you have any idea what could be wrong?

      In addition, if I try access any page use the context path such as http://localhost:8080/login.jsp, the page returns successfully., but if i try http://localhost:8080/ the jboss welcome page is rendered instead of login.jsp (this page is configured at welcome-file-list of web.xml)

      JBOSS-WEB.xml

      <jboss-web>
        <context-root>/</context-root>
      </jboss>
      

      STANDALONE.xml

      <subsystem xmlns="urn:jboss:domain:web:2.2" default-virtual-server="default-host" native="false">
        <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
        <virtual-server name="default-host" enable-welcome-root="false">
         <alias name="localhost"/>
         <alias name="example.com"/>
       </virtual-server>
      </subsystem>
      WEB.xml
      
      <welcome-file-list>
      <welcome-file>/login.jsp</welcome-file>
      </welcome-file-list>
      
      
        • 1. Re: EAP 6.4 - enable-welcome-root as false does not works
          Jay SenSharma Master

          Check your browser cache. Try from a fresh (a different) browser after clearing the cache.

           

          Also the change enable-welcome-root="false" restart, So did you restart JBoss EAP 6.4 after making that config change?    Also please check if you are starting the correct profile  "standalone.xml" (not other like standalone-full.xml). Better to verify the same using the CLI command:


          [standalone@localhost:9999 /] /subsystem=web/virtual-server=default-host:write-attribute(name=enable-welcome-root,value=false)
          {"outcome" => "success"}
          
          [standalone@localhost:9999 /] /subsystem=web/virtual-server=default-host:read-attribute(name=enable-welcome-root)
          {
              "outcome" => "success",
              "result" => false
          }
          
          [standalone@localhost:9999 /] :reload()
          {
              "outcome" => "success",
              "result" => undefined
          }
          
          
          

           

          • 2. Re: EAP 6.4 - enable-welcome-root as false does not works
            Junior Sousa Newbie


            Thank you Jay, the problem was due to browser cache.