2 Replies Latest reply on May 12, 2007 6:19 PM by Naimdjon Takhirov

    ConnectPool problem

    Naimdjon Takhirov Newbie

      Hi,
      I have now used a fair amount of time debugging, but am not able to find out what causes this problem. I am getting the old "No managed connection available within blocking timeout" error. The thing is that I have set up minimum of 5 and maximum of 30 connections in oracle-ds.xml. I am using oracle. When I check in TOAD(app. development environment for oracle) it shows that almost all of my connections' state is inactive. I was thinking this would mean that I do not close a connection somewhere. I have now gone through all SQLs that have inactive state and I it seems like I am closing all of them. ALso tried to

      <track-statements>true</track-statements>
      in that xml. It reports all result sets that have not been closed. However, I found one place where I try to close connection before preparedstatement. I have changed that but still getting the same error after a while.

      Checking in jmx-console did not help. The thing is that I do not know what configuration parameter I am looking for. Mostly the Mbean ( ManagedConnectionPool) has the parameters from oracle-ds.xml.

      Any tips would be appreciated.
      Thanks in advance.

      -C