2 Replies Latest reply on Oct 21, 2015 1:15 PM by anilaj

    Infinispan server 7.2.5 not starting in clustered mode

    anilaj Newbie

      Hi Tristan,

       

      I have ISPN server in a VM. I am trying to start the infinispan server in clustered mode using

       

      ./standalone.sh –c clustered.xml

       

      Infinispan server started without any errors with the below configuration:

      <interfaces>

          <interface name="management">

              <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>

          </interface>

          <interface name="public">

              <inet-address value="${jboss.bind.address:127.0.0.1}"/>

          </interface>

      </interfaces>

       

      But I was not able to connect to the ISPN server from a remote machine.

       

      So I changed the public interface binding in clustered.xml to <any-address/>. Now I am not able to start the server. It gives the below error:

       

      13:28:57,517 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC000001: Failed to start service jboss.jgroups.channel.clustered: org.jboss.msc.service.StartException in service jboss.jgroups.channel.clustered: java.net.BindException: [TCP] /0.0.0.0 is not a valid address on any local network interface

              at org.jboss.as.clustering.jgroups.subsystem.ChannelService.start(ChannelService.java:74)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881) [jboss-msc-1.2.2.Final.jar:1.2.2.Final]

              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_51]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_51]

             at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_51]

      Caused by: java.net.BindException: [TCP] /0.0.0.0 is not a valid address on any local network interface

              at org.jgroups.util.Util.checkIfValidAddress(Util.java:3480)

              at org.jgroups.stack.Configurator.ensureValidBindAddresses(Configurator.java:902)

              at org.jgroups.stack.Configurator.setupProtocolStack(Configurator.java:118)

              at org.jgroups.stack.Configurator.setupProtocolStack(Configurator.java:57)

              at org.jgroups.stack.ProtocolStack.setup(ProtocolStack.java:477)

              at org.jgroups.JChannel.init(JChannel.java:854)

              at org.jgroups.JChannel.<init>(JChannel.java:159)

              at org.jboss.as.clustering.jgroups.JChannelFactory.createChannel(JChannelFactory.java:87)

              at org.jboss.as.clustering.jgroups.subsystem.ChannelService.start(ChannelService.java:69)

              ... 5 more

       

      <?xml version="1.0" ?>

      <server xmlns="urn:jboss:domain:2.1">
      ...

      Here's the config file clustered.xml:

       

              <subsystem xmlns="urn:infinispan:server:endpoint:7.2">
                  <hotrod-connector socket-binding="hotrod" cache-container="clustered">
                      <topology-state-transfer lazy-retrieval="false" lock-timeout="1000" replication-timeout="5000"/>
                  </hotrod-connector>
                  <memcached-connector socket-binding="memcached" cache-container="clustered"/>
                  <rest-connector socket-binding="rest" cache-container="clustered" security-domain="other" auth-method="BASIC"/>
                  <websocket-connector socket-binding="websocket" cache-container="clustered"/>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:datasources:2.0">
                  <datasources/>
              </subsystem>
              <subsystem xmlns="urn:infinispan:server:core:7.2" default-cache-container="clustered">
                  <cache-container name="clustered" default-cache="default" statistics="true">
                      <transport executor="infinispan-transport" lock-timeout="60000"/>
                      <distributed-cache name="default" mode="SYNC" segments="20" owners="2" remote-timeout="30000" start="EAGER">
                          <locking acquire-timeout="30000" concurrency-level="1000" striping="false"/>
                          <transaction mode="NONE"/>
                      </distributed-cache>
                      <distributed-cache name="memcachedCache" mode="SYNC" segments="20" owners="2" remote-timeout="30000" start="EAGER">
                          <locking acquire-timeout="30000" concurrency-level="1000" striping="false"/>
                          <transaction mode="NONE"/>
                      </distributed-cache>
                      <distributed-cache name="namedCache" mode="SYNC" start="EAGER"/>
                      <distributed-cache name="transactionalCache" mode="SYNC" start="EAGER">
                          <transaction mode="NON_XA" locking="PESSIMISTIC"/>
                      </distributed-cache>
                    </cache-container>
                  <cache-container name="security"/>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:io:1.1">
                  <worker name="default"/>
                  <buffer-pool name="default"/>
              </subsystem>
               <subsystem xmlns="urn:infinispan:server:jgroups:7.0" default-stack="${jboss.default.jgroups.stack:udp}">
                  <stack name="udp">
                      <transport type="UDP" socket-binding="jgroups-udp"/>
                      <protocol type="PING"/>
                      <protocol type="MERGE3"/>
                      <protocol type="FD_SOCK" socket-binding="jgroups-udp-fd"/>
                      <protocol type="FD_ALL"/>
                      <protocol type="VERIFY_SUSPECT"/>
                      <protocol type="pbcast.NAKACK2"/>
                      <protocol type="UNICAST3"/>
                      <protocol type="pbcast.STABLE"/>
                      <protocol type="pbcast.GMS"/>
                      <protocol type="UFC"/>
                      <protocol type="MFC"/>
                      <protocol type="FRAG2"/>
                  </stack>
                  <stack name="tcp">
                      <transport type="TCP" socket-binding="jgroups-tcp"/>
                      <protocol type="MPING" socket-binding="jgroups-mping"/>
                      <protocol type="MERGE3"/>
                      <protocol type="FD_SOCK" socket-binding="jgroups-tcp-fd"/>
                      <protocol type="FD"/>
                      <protocol type="VERIFY_SUSPECT"/>
                      <protocol type="pbcast.NAKACK2">
                          <property name="use_mcast_xmit">false</property>
                      </protocol>
                      <protocol type="UNICAST3"/>
                      <protocol type="pbcast.STABLE"/>
                      <protocol type="pbcast.GMS"/>
                      <protocol type="MFC"/>
                      <protocol type="FRAG2"/>
                  </stack>
              </subsystem>
            ..
          <interfaces>
              <interface name="management">
                  <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
              </interface>
              <interface name="public">
                  <any-address/>
              </interface>
          </interfaces>
          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:100}">
              <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
              <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9993}"/>
              <socket-binding name="hotrod" port="11222"/>
              <socket-binding name="jgroups-mping" port="0" multicast-address="${jboss.default.multicast.address:234.99.54.14}" multicast-port="45700"/>
              <socket-binding name="jgroups-tcp" port="7600"/>
              <socket-binding name="jgroups-tcp-fd" port="57600"/>
              <socket-binding name="jgroups-udp" port="55200" multicast-address="${jboss.default.multicast.address:234.99.54.14}" multicast-port="45688"/>
              <socket-binding name="jgroups-udp-fd" port="54200"/>
              <socket-binding name="memcached" port="11211"/>
              <socket-binding name="rest" port="8080"/>
              <socket-binding name="txn-recovery-environment" port="4712"/>
              <socket-binding name="txn-status-manager" port="4713"/>
              <socket-binding name="websocket" port="8181"/>
          </socket-binding-group>
      </server>

       

      Please let me know what's wrong in this config:

       

      Thanks,