4 Replies Latest reply on Mar 16, 2016 5:53 AM by Ivan Leuzzi

    Wildfly 9.0.0. Final + mod_cluster1.3.1 + httpd 2.4.

    Domen Petric Newbie

      Hey everyone!

       

      I am trying to set up wildfly standalone cluster for few days but without success. I tried to set up from different examples for different Jbosses found around the web but nothing works.

       

      I installed two fedora 22 virtual machines. After i downloaded Wildfly 9.0.0. Final and start changing standalone-ha.xml. I also disabled firewall and selinux on both machines.

      Then i installed httpd 2.4. with yum's help and same with mod_cluster. It installed 2.6. version so i downloaded 1.3.1 and put *.so files in modules directory.

       

      After same basic configuration of mod_cluster i got working mod_cluster_manager that sees my nodes. When i want access to my app on port i got 404 page not found, but i can sea my app on alias myapp.si without a problem

       

      Please advise how to configure mod

        • 1. Re: Wildfly 9.0.0. Final + mod_cluster1.3.1 + httpd 2.4.
          Michal Karm Babacek Apprentice

          Dear Domen,

          Regarding RPM

          until Bug 1247243 – Review Request: mod_cluster - httpd modules and Tomcat/WildFly java libraries is resolved, it is strongly discouraged to use mod_cluster RPM available in Fedoras these days.

          Although, you can download recent mod_cluster 1.3.1.Final RPM fom Fedora People - karm.fedorapeople.org and build your rpm packages using rpmbuild. If you don't know how and you would still prefer RPM before tar/zip installation, I could build Fedora RPMs with mod_cluster 1.3.1 for httpd 2.4 for you (Fedora).

           

          Regarding configuration

          At a glance, it seems correct. On the other hand, it is mandatory for both machines being able to reach to each other. Could you tell us whether the status of your worker nodes on the Mod_cluster manager console is OK or NOTOK?

          Last but not least, share your logs -- Apache HTTP Server log on LogLevel Debug and you Wildfly log so as we could spot any suspicions undertakings.

           

          Cheers

          -K-

          • 2. Re: Wildfly 9.0.0. Final + mod_cluster1.3.1 + httpd 2.4.
            Domen Petric Newbie

            Hi Michal,

            thankyou for your reply.

            I removed installed mod_cluster and installed one that you provided in your reply.

            After installation i configure back mod_cluster and still didn't get wanted results. I am attaching logs from both wildflys and logs from httpd. Here is also a screenshot of mod_cluster_manager page.

             

            Node 2 is giving following error but thats new problem. That error i didn't get before new mod_cluster instalation.

            It says connection refused and i tried ping machines and connection works. I also saw second server on mod manager site yesterday, but cant see it today.

             

            YSRV0207: Starting subdeployment (runtime-name: "cloudflow-ejb.jar")

            13:22:53,323 ERROR [org.jboss.modcluster] (UndertowEventHandlerAdapter - 1) MODCLUSTER000043: Failed to send INFO command to localhost.localdomain/127.0.0.1:6666: Connection refused

             

            Screenshot_2.png

             

            Regards

            Domen

            • 3. Re: Wildfly 9.0.0. Final + mod_cluster1.3.1 + httpd 2.4.
              Domen Petric Newbie

              Hi again,

               

              sorry for bad error log previous time..

              Until now i changed fedora virtual machines for centos 6.7, installed httpd 2.4. and mod_cluster 1.3.1.

              At the moment i am trying to set up cluster with only one node. It should work anyway and i would simply add more nodes latter.

               

              [Tue Oct 27 14:15:16.015663 2015] [proxy:error] [pid 12077] (111)Connection refused: AH00957: ajp: attempt to connect to 10.0.2.6:12336 (10.0.2.6) failed

              As much as i understand this means mod_cluster wants to ping node to see if it is online. Since node didnt open that port, connection is refused and mod_cluster understands that as node is in error state. Am I right? How can i set port for pinging?

               

              Here is what i see in mod_cluster_manager and i am attaching all logs and config files. Only part that i am letting out is datasource in my standalone-ha.xml

               

              mod_cluster/1.3.1.Final

              start of "httpd.conf" configuration

              mod_proxy_cluster.c: OK

              mod_sharedmem.c: OK

              Protocol supported: AJP

              mod_advertise.c: OK

              Server: 192.168.2.246

              Server: 192.168.2.246 VirtualHost: *:80

              Server: nekineki.com VirtualHost: 10.0.2.6:6666 Advertising on Group 224.0.1.105 Port 23364 for http://10.0.2.6:6666 every 10 seconds

              end of "httpd.conf" configuration

               

              Auto Refresh show DUMP output show INFO output

              Node node1 (ajp://10.0.2.6:8009):

              Enable Contexts Disable Contexts Stop Contexts

              Balancer: mycluster,LBGroup: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 2,Ttl: 60000000,Status: NOTOK,Elected: 0,Read: 0,Transferred: 0,Connected: 0,Load: -1

              Virtual Host 1:

              Contexts:

              /, Status: ENABLED Request: 0 Disable Stop 

              Aliases:

              cloudflow 
              cloudflow.lcalhost 

               

               

              Thank you for your help

              • 4. Re: Wildfly 9.0.0. Final + mod_cluster1.3.1 + httpd 2.4.
                Ivan Leuzzi Newbie

                Hi, I have the same problem. Have you resolved it? I'm getting crazy for two weeks, and I don't have found any solution... Thanks.