1 Reply Latest reply on Nov 9, 2015 2:32 AM by Wolf-Dieter Fink

    Unable to enable infinispan index on wildfly 8.2.0

    Nantha Kumar Newbie

      I'm working with Wildfly 8.2.0 and trying to enable indexing for a infinispan cache. I've configured indexing properly, but still error thrown as "Indexing was not enabled on this cache". I hope dependency creating problem.

       

      Infinispan XML:

       

      <namedCache name="myCache">
       <indexing enabled="true" indexLocalOnly="true">
               <properties>
                  <property name="default.directory_provider" value="ram" />
               </properties>
        </indexing>
          <compatibility enabled="true"/>
      </namedCache>
      

       

      Code:

       

      QueryFactory qf = Search.getSearchManager(myCache).getQueryFactory();
      Query query = qf.from(myDO.class)
                  .having("allHierarhy").contains(groupId)
                  .toBuilder().build();
      List<ActiveCallDO> list = query.list();
      


      Above configurations were working fine as standalone java application. But when it comes to wildfly, throwing below error,


      java.lang.IllegalArgumentException: Indexing was not enabled on this cache. interface org.hibernate.search.spi.SearchFactoryIntegrator not found in registry
              at org.infinispan.query.impl.ComponentRegistryUtils.getComponent(ComponentRegistryUtils.java:27)
              at org.infinispan.query.impl.ComponentRegistryUtils.getComponent(ComponentRegistryUtils.java:20)
              at org.infinispan.query.impl.SearchManagerImpl.<init>(SearchManagerImpl.java:42)
              at org.infinispan.query.Search.getSearchManager(Search.java:17)
              at com.dataservices.MyCache.getActiveCalls(MyCache.java:124)
              at org.apache.jsp.admin.sipadmin.activeCallsManagement_jsp._jspService(activeCallsManagement_jsp.java:253)
              at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:69)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
              at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:366)
              at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:326)
              at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:259)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
      

       

      I've added below modules as dependency in MANIFEST.MF file,

      org.infinispan,org.infinispan.commons,org.infinispan.tree,org.hibernate,org.hibernate.search.engine,org.hibernate.search.orm,org.hibernate.hql,org.infinispan.query
      

       

      Please anyone help me to resolve the issue..

        • 1. Re: Unable to enable infinispan index on wildfly 8.2.0
          Wolf-Dieter Fink Master

          Hello,

          Did you mean you use Infinispan for your own purpose (not JavaEE related like session replication) and don't add the Infinispan bits as a module or include it to your application (not recommended)?

           

          I'm not 100% sure, but WildFly does not ship all Infinispan modules as it is 'only' designed to support JavaEE and therefore only the ISPN part with basic functionality is included.

          If you need more of ISPN you should add the ISPN WildFly modules (you can download it from infinispan.org). WIth these you can add a dependency and your application is able to use the latest ISPN features and version you need.

          Does that makes sense to you?