0 Replies Latest reply on Nov 11, 2015 9:20 AM by Paul Hinds

    How to enable RESTEasy logging

    Paul Hinds Newbie

      Hi Using JBoss AS64

       

      Per docs I have enabled

                  <logger category="org.jboss">

                      <level name="DEBUG"/>

                  </logger>

      and all these incase something is disabling them

                  <logger category="org.jboss.resteasy">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="org.jboss.resteasy.core">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="org.jboss.resteasy.plugins.providers">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="org.jboss.resteasy.plugins.server">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="org.jboss.resteasy.specimpl">

                      <level name="DEBUG"/>

                  </logger>

                  <logger category="org.jboss.resteasy.mock">

                      <level name="DEBUG"/>

                  </logger>

       

      I dont get any logs in server.log from org.jboss.resteasy when the server boots.  I get 2 log lines at runtime


      14:09:43,439 DEBUG [org.jboss.resteasy.resteasy_jaxrs.i18n] (http-/0.0.0.0:8280-1) RESTEASY000415: PathInfo: ....

       

      An no error logs for the 404.


      I have one Resource working, and another very similarly configured that gives 404 but no indication of why.

       

      In previous versions resteasy would print all the path s its mapping on boot if debug logging was installed.  I'm using what ever version of RESTEasy comes in the JBoss modules.