3 Replies Latest reply on Nov 30, 2015 3:19 AM by Sreekanth Munarai

    Clustering issue JBoss with mod_cluster

    Sreekanth Munarai Master

      Hi All,

       

      INFO:

      JDK1.6

      JBoss7.1.1AS

      mod_cluster-1.1.3.Final-windows-x64-ssl(httpd2.2)

       

       

      I'm trying to set-up Clustering in two separate boxes. Clustering is completed, things are working as expected. Master and Slave are responding as they should. With below statement in logs:

      JBAS010918: Registered remote slave host "slave",


      and i'm able to access deployed war file from both the servers.

       

      But when I'm trying to in-front Apache web server with mod_cluster, connection is getting refused. with below error in JBoss logs:

       

      [Server:server-three] 13:17:10,704 INFO  [org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) IO e

      rror sending command INFO to proxy domain.com/IP:10001: java.net.ConnectException: Connection refused: connect

      [Server:server-three]  at java.net.PlainSocketImpl.socketConnect(Native Method) [rt.jar:1.6.0_35]

      [Server:server-three]  at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351) [rt.jar:1.6.0_35]


      Been googling about issue, have founded a solution as i have add "EnableMCPMReceive On", but when i add it my httpd.conf file Apache isn't starting and getting below error:

      Invalid command 'EnableMCPMReceive', perhaps misspelled or defined by a module not included in the server configuration

       

      Can any one suggest me how can i resolve this issue?

       

      Thanks,

      Sreekanth

        • 1. Re: Clustering issue JBoss with mod_cluster
          Jay SenSharma Master

          Sreekanth,

           

             Looks like either your "proxy-list="host:xxxx"   is not configured properly in your JBoss domain.xml means it might not be pointing to the apache host and port.   

             (OR) Your apache might not be listening on the mentioned port.  So try starting the apache and then from the JBoss host just try to telnet that host port of apache to see of you get connected or not.

           

          telnet apacheHost  Port

          telnet  10.20.20.45  80

           

             Also you can refer to  the following article to see if the steps are followed correctly?

           

          Using mod_cluster with JBoss AS 7.1 cluster Domain mode.

          http://middlewaremagic.com/jboss/?p=2147

           

          Regards

          Jay SenSharma

          • 2. Re: Clustering issue JBoss with mod_cluster
            Sreekanth Munarai Master

            Jay,

             

            Thanks for your suggestions. Please find the below configuration done in JBoss:

             

            <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" instance-id="${jboss.node.name}" native="false">

                            <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                            <connector name="ajp" protocol="AJP/1.3" scheme="http" socket-binding="ajp"/>

                            ---

                            </virtual-server>

             

             

            <subsystem xmlns="urn:jboss:domain:modcluster:1.0">

                            <mod-cluster-config advertise-socket="modcluster" proxy-list="IP:10001" advertise="true" advertise-security-key="Dev_Cluster">

                                <dynamic-load-provider>

                                    <load-metric type="busyness"/>

                                </dynamic-load-provider>

                            </mod-cluster-config>

                        </subsystem>

             

            Apache Configuration:

             

            <IfModule manager_module>

              Listen IP:10001

              ManagerBalancerName mycluster

              <VirtualHost IP:10001>

                <Location />

                Order deny,allow

                Deny from all

                Allow from SUBIP.

                </Location>

                KeepAliveTimeout 300

                MaxKeepAliveRequests 0

              EnableMCPMReceive On

                AllowDisplay On

                #ServerAdvertise on http://@@MCMPIP@@:@@MCMPPORT@@

              ManagerBalancerName other-server-group

                AdvertiseFrequency 5

                #AdvertiseSecurityKey secret

                #AdvertiseGroup @@ADVIP@@:23364

                <Location /mod_cluster_manager>

                  SetHandler mod_cluster-manager

                  Order deny,allow

                  Deny from all

                  Allow from SUBIP

                </Location>

              </VirtualHost>

            </IfModule>



            NOTE: We are running Apache and JBoss master on same server.

             

            and yes i tried telnet, both ports are open(80 and 10001 )

             

            Please advise.

             

            Thanks

            • 3. Re: Clustering issue JBoss with mod_cluster
              Sreekanth Munarai Master

              Any updates/ advises folks??got struck at same error!