2 Replies Latest reply on Nov 27, 2015 4:29 AM by Brendan Edmonds

    Memory Leak I can't seem to find.

    Brendan Edmonds Newbie

      Hi,

       

      I am trying to find a memory leak in my JSF JBoss application (the problem occurs on the latest versions of both EAP, and wildfly). If I run this command from the command line (in production, the application runs out of memory after about 2 days):

       

      ab -n $((16#10000))  -c 10 'http://localhost:8080/progname/index.jsf'

       

      Which just requests http://localhost:8080/progname/index.jsf 1048576 times with 10 concurrent connections.

       

      EAP (or Wildfly 9) eventually fails with a OOM Exception (in Hibernate, JDBC). I tried using VisiualVM, however it doesn't give me any useful information. Most of the memory is used by byte[] objects or ConcurrentHashMap, inspecting a heap dump doesn't give me any more clues either.

       

      Next I tried removing everything inside index.xhtml, leaving just <html></html>, and still the same problem.

       

      I am at a lost at the moment as to where to goto next. Any suggestions?

       

      Thanks

       

      Brendan