0 Replies Latest reply on Dec 1, 2015 6:26 PM by Michal Siplak

    HQ209002: the specified string is too long

    Michal Siplak Newbie

      Hi,

       

      we use jbpm 6.1 running on  wildfly 8.1Final  and hornet messaging. For some (for me unknown) reason we got Exception when jbpm tries to create response message. Exception complains about length of message. I realy don't know if this kind of message must be treat like a large message or not. If I understand LargeMessge is when message is really big (KB, MB, GB) but here UTF8Util check length 255. Do I have to set something in messaging ? For example in javadoc ByteMessage there is nothing about length of message. Any idea how can I avoid this exception ?

       

      Thanks

      Michal

       

      Here is Stack trace and below there is our hornetq settings:

       

      Caused by: javax.jms.JMSException: Failed to write UTF

              at org.hornetq.jms.client.HornetQBytesMessage.writeUTF(HornetQBytesMessage.java:315) [hornetq-jms-client-2.4.1.Final.jar:]

              at org.kie.remote.services.jms.RequestMessageBean.serializeResponse(RequestMessageBean.java:334) [kie-services-remote-6.1.0.Final.jar:6.1.0.Final]

              ... 81 more

      Caused by: java.lang.IllegalStateException: HQ209002: the specified string is too long (258,663)

              at org.hornetq.utils.UTF8Util.saveUTF(UTF8Util.java:51) [hornetq-commons-2.4.1.Final.jar:]

              at org.hornetq.core.buffers.impl.ChannelBufferWrapper.writeUTF(ChannelBufferWrapper.java:200) [hornetq-commons-2.4.1.Final.jar:]

              at org.hornetq.core.buffers.impl.ResetLimitWrappedHornetQBuffer.writeUTF(ResetLimitWrappedHornetQBuffer.java:380) [hornetq-core-client-2.4.1.Final.jar:]

              at org.hornetq.jms.client.HornetQBytesMessage.writeUTF(HornetQBytesMessage.java:311) [hornetq-jms-client-2.4.1.Final.jar:]

              ... 82 more

       

      HornetQ settings:

      <hornetq-server>

                  <persistence-enabled>true</persistence-enabled>

                  <security-enabled>false</security-enabled>

                  <create-journal-dir>true</create-journal-dir>

                  <journal-type>ASYNCIO</journal-type>

                  <journal-buffer-timeout>500000</journal-buffer-timeout>

                  <journal-buffer-size>1048576</journal-buffer-size>

                  <journal-sync-transactional>true</journal-sync-transactional>

                  <journal-sync-non-transactional>true</journal-sync-non-transactional>

                  <journal-file-size>10485760</journal-file-size>

                  <journal-min-files>2</journal-min-files>

                  <journal-compact-percentage>30</journal-compact-percentage>

                  <journal-compact-min-files>10</journal-compact-min-files>

                  <journal-max-io>1024</journal-max-io>

                  <transaction-timeout>50000000</transaction-timeout>