3 Replies Latest reply on Feb 3, 2016 9:53 AM by Brian Stansberry

    Deploy error in Wildfly 9.0.2

    Ricardo Francisco Newbie

      I cant deploy a war package in wildfly 9.0.2 but it works in 9.0.1. The error is:

       

      ERROR [io.undertow.request] (XNIO-1 task-2) Undertow request failed

      HttpServerExchange{ POST /management-upload}: java.io.IOException: UT000036: Connection terminated parsing multipart data

      at io.undertow.server.handlers.form.MultiPartParserDefinition$MultiPartUploadHandler.parseBlocking(MultiPartParserDefinition.java:203)

      at org.jboss.as.domain.http.server.DomainApiGenericOperationHandler.handleRequest(DomainApiGenericOperationHandler.java:104)

      at io.undertow.server.handlers.encoding.EncodingHandler.handleRequest(EncodingHandler.java:72)

      at org.jboss.as.domain.http.server.security.SubjectDoAsHandler$1.run(SubjectDoAsHandler.java:72)

      at org.jboss.as.domain.http.server.security.SubjectDoAsHandler$1.run(SubjectDoAsHandler.java:68)

      at java.security.AccessController.doPrivileged(Native Method)

      at javax.security.auth.Subject.doAs(Subject.java:422)

      at org.jboss.as.controller.AccessAuditContext.doAs(AccessAuditContext.java:92)

      at org.jboss.as.domain.http.server.security.SubjectDoAsHandler.handleRequest(SubjectDoAsHandler.java:68)

      at org.jboss.as.domain.http.server.security.SubjectDoAsHandler.handleRequest(SubjectDoAsHandler.java:63)

      at io.undertow.server.handlers.BlockingHandler.handleRequest(BlockingHandler.java:56)

      at org.jboss.as.domain.http.server.DomainApiCheckHandler.handleRequest(DomainApiCheckHandler.java:87)

      at io.undertow.security.handlers.AuthenticationCallHandler.handleRequest(AuthenticationCallHandler.java:52)

      at io.undertow.server.Connectors.executeRootHandler(Connectors.java:199)

      at io.undertow.server.HttpServerExchange$1.run(HttpServerExchange.java:774)

      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

      at java.lang.Thread.run(Thread.java:745)

       

      In my case this happens right after a fresh install in Ubuntu 14 server.


      Adicional note: Someone on stackexchange noticed that it works if the upload is performed on Firefox, but it fails if the upload is performed in IE and Chrome.