0 Replies Latest reply on Dec 9, 2015 6:38 AM by Pankaj Pathak

    RMI Configuration in JBoss 7

    Pankaj Pathak Newbie

      Hi There,

       

      Our current application is configured using RMI protocol. Now we are migrating the same on JBoss7.2 and JDK 1.7 versons.

      Since JBoss 7 has removed the support of RMI, could any one help on this as how can we configure RMI in JBoss 7?

       

      Below one is code snippet -

       

      Service configuration -

       

      <bean id="claimsOSRMIRegistry" class="org.springframework.remoting.rmi.RmiRegistryFactoryBean">

           <property name="port" value="${rmi.port}" />

        </bean>

       

       

        <!-- Exposing RMI services starts -->

        <bean id="reportedClaimService" class="org.springframework.remoting.rmi.RmiServiceExporter">

        <property name="serviceName" value="${context.root}ReportedClaimService"/>

        <property name="service">

        <ref bean="reportedClaimServiceProxy" />

        </property>

        <property name="serviceInterface" value="com.claimsos.claim.ReportedClaimService"/>

        <property name="registry">

        <ref bean="claimsOSRMIRegistry"/>

        </property>

        <property name="registerTraceInterceptor" value="false"/>

        </bean>

       

      Client Configuration -

      <bean id="reportedClaimService"

        class="org.springframework.remoting.rmi.RmiProxyFactoryBean">

        <property name="serviceUrl"

        value="${rmi.service.location}ReportedClaimService" />

        <property name="serviceInterface"

        value="com.claimsos.claim.ReportedClaimService" />

        <property name="lookupStubOnStartup" value="false" />

        <property name="refreshStubOnConnectFailure" value="true" />

        </bean>

       

      Here is my RMI port configuration -

       

      rmi.port=1199

      rmi.service.location=rmi://localhost:${rmi.port}/${context.root}

       

      If any once has any suggestion or have come a crossed this, Please do share.

       

      Thanks

      Pankaj