1 Reply Latest reply on Dec 16, 2015 5:07 AM by Claus Ibsen

    [Fuse 6.2.1] Error for creation of Performance.Counter.Server MBean

    Kunal Suri Newbie

      Hi,

       

      While trying to use the SOAP quick start example in the Fuse 6.2.1, I tried to add the below Bean in the blueprint.xml file so as to start the monitoring of the Web-service, but the project build is failing.

       

      <bean id="org.apache.cxf.management.counters.CounterRepository"

          class="org.apache.cxf.management.counters.CounterRepository">

      <property name="bus" ref="cxf" />

      </bean>

      I am also using Fuse 6.1 and the bean code works on it. I also tried to give the below verision with the dofferent ID name (just to be sure) but I am getting the same error.

       

      Source: Apache CXF -- JMX Management

      <!-- Wiring the counter repository -->

       

      <bean id="CounterRepository" class="org.apache.cxf.management.counters.CounterRepository">

          <property name="bus" ref="cxf" />

      </bean>


       

      I also added the dependency for the management Mbean as per below and I think its working fine.

       

      <dependency>

           <groupId>org.apache.cxf</groupId>

          <artifactId>cxf-rt-management</artifactId>

          <version>3.0.4.redhat-621084</version>

      </dependency>

       

       

      Error:

       

      [INFO] --- maven-bundle-plugin:2.3.7:bundle (default-bundle) @ cxf-soap ---

      [ERROR] Bundle org.jboss.quickstarts.fuse:cxf-soap:bundle:6.2.1.redhat-084 : Unresolved references to [org.apache.cxf.management.counters] by class(es) on the Bundle-Classpath[Jar:dot]: []

      [ERROR] Error(s) found in bundle configuration

      [INFO] ------------------------------------------------------------------------

      [INFO] BUILD FAILURE

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 5.240 s

      [INFO] Finished at: 2015-12-13T10:42:36+01:00

      [INFO] Final Memory: 22M/219M

      [INFO] ------------------------------------------------------------------------

      [ERROR] Failed to execute goal org.apache.felix:maven-bundle-plugin:2.3.7:bundle(default-bundle) on project cxf-soap: Error(s) found in bundle configuration ->[Help 1]

      [ERROR]

      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

       

      Could you please suggest what could be going wrong? Do I need to add or install any special features or something in Fuse to enable the web-service management?