2 Replies Latest reply on Dec 16, 2015 11:10 AM by Paul Ferraro

    JGRP000015: the send buffer of socket DatagramSocket was set to 640KB, but the OS only allocated 212.99KB. This might lead to performance problems. Please set your max send buffer in the OS correctly (e.g. net.core.wmem_max on Linux)

    Hristo Stoyanov Master

      The above message indicates mismatch between JGroups and the Linux kernel settings when running Wildfly 9.0.2 with ha/clustering. In many situations the Linux kernel settings can not be changed, therefore I attempted to adjust JGroups in my Wildfly server instead. However, this did not work:

      ========================================

      <subsystem xmlns="urn:jboss:domain:jgroups:3.0">

      ...

         <stacks default="udp">

             <stack name="udp">

                ....

                <protocol type="mcast_recv_buf_size">130K</protocol>

             </stack>

      ...

      =========================================

       

      Any idea how to do it properly in WF 9.0.2? Thanks.