1 Reply Latest reply on Nov 14, 2007 5:07 PM by Mike Darretta

    STILL HAVING ISSUES...Neither EJB 2.1 or 3.0 are deployed

    Mike Darretta Newbie

      I have sent a number of conflicting messages due to various circumstances, but my bottom line now is that neither my 2.1 nor 3.0 beans deploy. My environment is JBoss 4.0.3SPI (with RC5 update), Redhat Linux 3.5 ES, Java 1.5.0_12, J2EE 5 persistence apis....


      Here is what I've done thus far:

      (1) Cleaned all jars/ears/wars of outside jar imports - I now rely 100% on JBoss supplied libraries

      (2) Packaged my product as so:

      myapp.ear
       |
       -- META-INF/application.xml
       |
       -- myapp-ejb.jar
       |
       -- META-INF/persistence.xml
       |
       -- META-INF/ejb-jar.xml
       |
       -- META-INF/jbosscmp-jdbc.xml
       |
       -- META-INF/jboss.xml
       |
       -- myapp-war.war
       |
       -- WEB-INF/web.xml
      


      (Note that EJB 2.1 and 3.0 beans are in the same ejb.jar file).

      Below is my persistence.xml:
      <?xml version="1.0" encoding="UTF-8"?>
      <persistence version="1.0" xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_1_0.xsd">
       <persistence-unit name="vramPu" transaction-type="JTA">
       <provider>org.hibernate.ejb.HibernatePersistence</provider>
       <jta-data-source>java:/nicweb/DataSource</jta-data-source>
       <properties>
       <property name="hibernate.hbm2ddl.auto" value="update"/>
       </properties>
       </persistence-unit>
      </persistence>


      Here is the declaration for my web.xml:

      <?xml version="1.0" encoding="UTF-8"?>
      <web-app version="2.5" xmlns="http://java.sun.com/xml/ns/javaee" xmlns:xsi="http
      ://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/x
      ml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">
       <display-name>vram-dos</display-name>


      Here is my application.xml:
      <?xml version="1.0" encoding="UTF-8"?>
      <application version="5" xmlns="http://java.sun.com/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/application_5.xsd">
      
       <display-name>vram-dos-server</display-name>
      
       <!-- Service configurations -->
       <module>
       <ejb>nicweb-jboss-ds.xml</ejb>
       </module>
      
       <module>
       <ejb>mail-service.xml</ejb>
       </module>
      
       <module>
       <ejb>vram-dos-server-ejb.jar</ejb>
       </module>
      
       <module>
       <web>
       <web-uri>vram-dos-server-war.war</web-uri>
       <context-root>/vram-dos-server-webapp</context-root>
       </web>
       </module>
      
      </application>


      Any help is appreciated.

      Thanks,
      Mike