1 Reply Latest reply on Dec 26, 2015 12:35 PM by Jay SenSharma

    Internal server error on Wildfly 8.2.0

    József Mester Newbie

      Hello and Merry Christmas

       

      I have a maven web application, which contains only REST services. This

      is a very basic application. The whole app created with Netbeans auto

      generate tools.

      I have a Debian Wheezy server and when I deploy my war everything is

      good, but some hours later REST service is not respond, and I only got

      Internal Server Error.

      I had to disable my application , after I have to disable Datasource, re

      enable datasource, and after that re deploy my program.

       

      Log:

      33m08:57:20,799 WARN [org.hibernate.engine.jdbc.spi.SqlExceptionHelper]

      (default task-3) SQL Error: 0, SQLState: 08S01

        [0m [31m08:57:20,800 ERROR

      [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] (default task-3) The

      last packet successfully received from the server was 58,901,043

      milliseconds ago.  The last packet sent successfully to the server was

      58,901,043 milliseconds ago. is longer than the server configured value

      of 'wait_timeout'. You should consider either expiring and/or testing

      connection validity before use in your application, increasing the

      server configured values for client timeouts, or using the Connector/J

      connection property 'autoReconnect=true' to avoid this problem.

        [0m [31m08:57:20,805 ERROR [org.jboss.as.ejb3.invocation] (default

      task-3) JBAS014134: EJB Invocation failed on component PartnerFacadeREST

      for method public java.util.List

      com.joco.nyomtserv2.service.PartnerFacadeREST.findAll():

      javax.ejb.EJBException: javax.persistence.PersistenceException:

      org.hibernate.exception.JDBCConnectionException: could not extract ResultSet

       

      How can I set the timeout or the autoReconnect?

       

      Thank you.

       

      Joe

        • 1. Re: Internal server error on Wildfly 8.2.0
          Jay SenSharma Master

          Hello Joe,

           

          If your hibernate/persistence is using WildFly DataSource then in that datasource you can add the following validation entry which will enable the background validation of the Pooled DataSource connections.

                    <validation>
                        <check-valid-connection-sql>select 1</check-valid-connection-sql>
                        <validate-on-match>false</validate-on-match>
                        <background-validation>true</background-validation>
                        <background-validation-millis>10000</background-validation-millis>
                    </validation>
          

           

           

          If your application is purely using the hibernate, then you may try setting the hibernate auto reconnect property in your hibernate configuration file as following:

          <hibernate-configuration>
              <session-factory>      
                   <property name="connection.autoReconnect"> true</property>
                   .
                   .
              </session-factory>
          </hibernate-configuration>
          

           

          Regards

          Jay SenSharma