0 Replies Latest reply on Jan 8, 2016 4:18 PM by Noor Shaikh

    Does Jbpm 6.X versions supports JPA 1 for persistence mechanism?

    Noor Shaikh Newbie

      Does Jbpm 6.X versions supports JPA 1 for persistence mechanism?

       

      My existing project uses hibernate3.jar

       

      And for using JBPM 6.X in my project, I have also included below hibernate jars.

       

       

      hibernate-commons-annotations-4.0.2.Final-redhat-1.jar

      hibernate-core-4.2.18.Final-redhat-2.jar

      hibernate-entitymanager-4.2.18.Final-redhat-2.jar

      hibernate-jpa-2.0-api-1.0.1.Final-redhat-3.jar

       

      And I am encountering below exceptions, could you please confirm that I will have to exclude using hibernate3.jar in order to avoid below exception.

       

      In short, please confirm  if Jbpm 6.X versions supports JPA 1 for persistence mechanism or it supports only JPA 2 ?

       

      [15:24:32,128] INFO org.springframework.orm.jpa.LocalContainerEntityManagerFactoryBean - Building JPA container EntityManagerFactory for persistence unit 'org.jbpm.persistence.jpa'

       

      [15:24:32,350] INFO org.hibernate.ejb.Ejb3Configuration - HHH000204: Processing PersistenceUnitInfo [

       

            name: org.jbpm.persistence.jpa

       

            ...]

       

      [15:24:44,805] ERROR org.hibernate.internal.util.xml.ErrorLogger - HHH000198: Warning parsing XML (6) : schema_reference.4: Failed to read schema document 'orm_2_0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.

       

      schema document 'orm_1_0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.

       

      [15:24:44,847] ERROR org.hibernate.internal.util.xml.ErrorLogger - HHH000196: Error parsing XML (2) : cvc-elt.1.a: Cannot find the declaration of element 'entity-mappings'