5 Replies Latest reply on Oct 26, 2017 8:54 AM by Tech Thread

    Modified process and "ClassCastException: SubProcessNode cannot be cast to HumanTaskNode"

    Gianluca Merendino Newbie

      Hi,

       

      In my jBPM 6.0.1 production installation I had a process with running instance.

      I modified this process in a development installation and downloaded the jar file of the modified process from the Artifact Repository.

      Then I uploaded this jar file in the production installation by the "Artifact Repository" in kie workbench.

      Now in the production installation the instances started previously are working with the modified version of the process.

       

      It works fine, except a task. When I tried to complete it, I get this error:

      ClassCastException: org.jbpm.workflow.core.node.SubProcessNode cannot be cast to org.jbpm.workflow.core.node.HumanTaskNode

       

      I'd like to know:

      - It's correct to modify a process as I did ?

      - Why I have this error ? what happens internally ? I tried a search for clues in the DB (specially in the table 'NodeInstanceLog'), but everything seems correct.

       

      Thanks