12 Replies Latest reply on Apr 11, 2016 2:32 AM by ehugonnet

    unable to deploy business-central.war on EAP in domain mode

    Deepali Chourasia Newbie

      I have downloaded jboss-brms-6.0.3.GA-redhat-1-deployable-eap6.x.zip and am trying to deploy it on fresh EAP 6.1 instance in domain mode. But it is not getting successful.

      I followed the instructions given at https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_BRMS/6.0/html/Installation_Guide/Installing_BRMS_in_the_Domain_Mode.html.

      However, I am getting following when I try to deploy the business-central.war archive.

       

      ./jboss-cli.sh

      You are disconnected at the moment. Type 'connect' to connect to the server or 'help' for the list of supported commands.

      [disconnected /] connect

      [domain@localhost:9999 /] deploy BAS015874: JBoss BRMS 6.0.3.GA (AS 7.2.1.Final-redhat-10) (Host Controller) started in 4968ms - St[root@pts00434-vm5 bin]# ./jboss-cli.sh

      You are disconnected at the moment. Type 'connect' to connect to the server or 'help' for the list of supported commands.

      [disconnected /] connect

      [domain@localhost:9999 /] deploy --all-server-groups /root/deepali/JBOSS/brms_603_deployable/jboss-eap-6.1/standalone/deployments/business-central.war/business-central.war

      JBAS010839: Operation failed or was rolled back on all servers.

       

       

      The server log shows the following:

      [Host Controller] 14:23:45,597 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990

      [Host Controller] 14:23:45,598 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss BRMS 6.0.3.GA (AS 7.2.1.Final-redhat-10) (Host Controller) started in 4968ms - Started 11 of 11 services (0 services are passive or on-demand)

      [Host Controller] 14:25:38,312 INFO  [org.jboss.as.repository] (management-handler-thread - 4) JBAS014900: Content added at location /root/deepali/JBOSS/jboss-eap-6.1/domain/data/content/ac/464f7f16481a6421684a9f106ea2bbb0879b5e/content

      [Server:server-one] 14:25:40,853 ERROR [org.jboss.as.server] (host-controller-connection-threads - 1) JBAS015870: Deploy of deployment "business-central.war" was rolled back with the following failure message: {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.deployment.unit.\"business-central.war\" is missing [jboss.deployment.chains]"]}

      [Server:server-two] 14:25:40,946 ERROR [org.jboss.as.server] (host-controller-connection-threads - 1) JBAS015870: Deploy of deployment "business-central.war" was rolled back with the following failure message: {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.deployment.unit.\"business-central.war\" is missing [jboss.deployment.chains]"]}

       

      Please let me know how I can resolve this issue.

        • 1. Re: unable to deploy business-central.war on EAP in domain mode
          Deepali Chourasia Newbie

          Any ideas how I can get BRMS working with EAP in domain mode?

          • 2. Re: unable to deploy business-central.war on EAP in domain mode
            Deepali Chourasia Newbie

            Please let me know if anyone else has seen similar issue?

            • 3. Re: unable to deploy business-central.war on EAP in domain mode
              Wolf-Dieter Fink Master

              Did you see any warnings or other messages before this?

              • 4. Re: unable to deploy business-central.war on EAP in domain mode
                Mahesh Kumar Newbie

                look like your using long strings copy the .war file to deploy --all-server-groups /root/deepali/business-central.war and try hopes it will help.

                if its not working deploy the war file each group

                deploy /tmp/business-central.war --server-groups=<group name>

                Thanks !!


                • 5. Re: unable to deploy business-central.war on EAP in domain mode
                  Deepali Chourasia Newbie

                  Hello,

                   

                  I tried this again today using the following:

                  jboss-eap-6.4.0.zip, jboss-eap-6.4.4-patch.zip, jboss-brms-6.2.0.GA-deployable-eap6.x.zip.

                  The deployment is not successful yet.

                   

                  The steps I tried are:

                  1. Extracted jboss-eap-6.4.0.zip and applied jboss-eap-6.4.4-patch.zip on it.

                  2. Extracted jboss-brms-6.2.0.GA-deployable-eap6.x.zip.

                  3. Copied bin and domain directories supplied with boss-brms-6.2.0.GA-deployable-eap6.x.zip to EAP 6.4.

                  4. Created business-central.war using the command

                      jar -cvf business-central.war *

                  5. Executed command to deploy the war on the EAP server

                  bin/jboss-cli.sh

                  You are disconnected at the moment. Type 'connect' to connect to the server or 'help' for the list of supported commands.

                  [disconnected /] connect

                  [domain@localhost:9999 /] deploy /tmp/business-central.war

                  One of --disabled, --all-server-groups or --server-groups is missing.

                  [domain@localhost:9999 /] deploy --all-server-groups /tmp/business-central.war

                  JBAS010839: Operation failed or was rolled back on all servers.

                   

                  The following warning are observed on the server console:

                  [Server:server-two] 11:34:06,415 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry jaxb-api.jar in /content/business-central.war/WEB-INF/lib/jaxb-core-2.2.11.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,424 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry avalon-framework-4.2.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,424 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry batik-all-1.7.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,425 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry commons-io-1.3.1.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,425 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry commons-logging-1.0.4.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,425 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry serializer-2.7.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,425 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry servlet-2.2.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,426 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry xalan-2.7.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,426 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry xercesImpl-2.7.1.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,426 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry xml-apis-1.3.04.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,426 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry xml-apis-ext-1.3.04.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,427 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry xmlgraphics-commons-1.3.1.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,427 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry fop-hyph.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,427 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry jai_codec.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,427 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry jai_core.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,427 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry jai_imageio.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,428 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry jimi-1.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,428 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry xmlunit1.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,476 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015960: Class Path entry jaxb-core.jar in /content/business-central.war/WEB-INF/lib/jaxb-impl-2.2.11.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,538 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jaxb-api.jar in /content/business-central.war/WEB-INF/lib/jaxb-core-2.2.11.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,546 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry avalon-framework-4.2.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,546 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry batik-all-1.7.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,547 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry commons-io-1.3.1.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,547 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry commons-logging-1.0.4.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,547 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry serializer-2.7.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,547 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry servlet-2.2.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,547 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xalan-2.7.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,548 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xercesImpl-2.7.1.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,548 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xml-apis-1.3.04.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,548 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xml-apis-ext-1.3.04.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,548 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xmlgraphics-commons-1.3.1.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,549 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry fop-hyph.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,549 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jai_codec.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,549 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jai_core.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,549 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jai_imageio.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,550 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jimi-1.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,550 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry xmlunit1.0.jar in /content/business-central.war/WEB-INF/lib/fop-0.95.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-one] 11:34:06,598 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015960: Class Path entry jaxb-core.jar in /content/business-central.war/WEB-INF/lib/jaxb-impl-2.2.11.jar  does not point to a valid jar for a Class-Path reference.

                  [Server:server-two] 11:34:06,667 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015893: Encountered invalid class name 'org.xmlpull.mxp1.MXParser,org.xmlpull.mxp1_serializer.MXSerializer' for service type 'org.xmlpull.v1.XmlPullParserFactory'

                  [Server:server-one] 11:34:06,846 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-11) JBAS015893: Encountered invalid class name 'org.xmlpull.mxp1.MXParser,org.xmlpull.mxp1_serializer.MXSerializer' for service type 'org.xmlpull.v1.XmlPullParserFactory'

                   

                  I am attaching the full console output as well for reference.

                  Please let me know if I am missing any step here.

                   

                  Regards

                  Deepali

                  • 6. Re: unable to deploy business-central.war on EAP in domain mode
                    Mahesh Kumar Newbie

                    look like its java compatibility issues

                    Jboss 6.x will user Java 1.7.x

                    what is the java version of business-central.war ?if its using lower version of java you need to compile the  all class file. and also check the class path reference.

                    i hops all jar file are copied in .war/WEB-INF/lib if its not there copy in to inside modules

                    exp :-

                    modules/com/<project name>/mymodule/main

                    copy the all jar file to this path

                    create the module.xml update the below the entry

                    <?xml version="1.0" encoding="UTF-8"?>

                    <module xmlns="urn:jboss:module:1.1" name="com.<projectname>.mymodule">

                    <resources>

                    <resource-root path="."/>

                    </resources>

                    </module>

                    Hops it will help


                    Thanks

                    Mahesh



                     

                    • 7. Re: unable to deploy business-central.war on EAP in domain mode
                      Deepali Chourasia Newbie

                      The major minor versions for the .war file is:

                        Compiled from "AppSetup.java"

                        public class org.kie.workbench.drools.backend.server.AppSetup

                        minor version: 0

                        major version: 50

                       

                      I am using openjdk version "1.8.0_71" on my machine. Do you recommend to use 1.6 or 1.7 version of java?

                      • 8. Re: unable to deploy business-central.war on EAP in domain mode
                        Deepali Chourasia Newbie

                        I gave a try using JDK7, but the deployment failed with it as well.

                         

                        A number of exceptions are seen in the server log. Attaching the complete console log here. Please let me know if this indicates any more issues in the setup.

                         

                        Regards

                        Deepali

                        • 9. Re: unable to deploy business-central.war on EAP in domain mode
                          ehugonnet Apprentice

                          You have an issue in your application as it is opening a port for each server instance:

                          Caused by: org.uberfire.java.nio.IOException: java.io.IOException: Failed to open server socket for /127.0.0.1:9418

                          I guess you should configure some parameter to open a different port on each server instance using system properties for each server (Chapter 9. Workbench)

                          • 10. Re: unable to deploy business-central.war on EAP in domain mode
                            Deepali Chourasia Newbie

                            Hi,

                             

                            I am not sure if I got it right. The configuration in the domain's host.xml is like:

                             

                                <servers>

                                    <server name="server-one" group="main-server-group">

                                        <!-- Remote JPDA debugging for a specific server

                                        <jvm name="default">

                                          <jvm-options>

                                            <option value="-agentlib:jdwp=transport=dt_socket,address=8787,server=y,suspend=n"/>

                                          </jvm-options>

                                       </jvm>

                                       -->

                                    </server>

                                    <server name="server-two" group="main-server-group" auto-start="true">

                                        <!-- server-two avoids port conflicts by incrementing the ports in

                                             the default socket-group declared in the server-group -->

                                        <socket-bindings port-offset="150"/>

                                    </server>

                                    <server name="server-three" group="other-server-group" auto-start="false">

                                        <!-- server-three avoids port conflicts by incrementing the ports in

                                             the default socket-group declared in the server-group -->

                                        <socket-bindings port-offset="250"/>

                                    </server>

                                </servers>

                             

                            So looks like that the ports are set at different offsets for each of the server. But still I am getting that error. Any idea where exactly I need to make the port config related change.

                            • 11. Re: unable to deploy business-central.war on EAP in domain mode
                              Deepali Chourasia Newbie

                              Meanwhile I was trying something and I commented one of the two server groups which is configured by default in the domain.xml, so that it only has main-server-group now.

                               

                              And I tried to deploy on the particular server group:

                              deploy /tmp/business-central.war --server-groups=main-server-group

                               

                              The next set of log that I took has the following exception:

                              [Server:server-two] Caused by: java.lang.RuntimeException: org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out: NativeFSLock@/root/deepali/JBOSS/BRMS_22March/jboss-eap-6.4/.index/datasets/write.lock

                              [Server:server-two]    at org.uberfire.ext.metadata.backend.lucene.index.directory.DirectoryLuceneIndex.<init>(DirectoryLuceneIndex.java:53)

                              [Server:server-two]    at org.uberfire.ext.metadata.backend.lucene.index.directory.DirectoryType$2.newIndex(DirectoryType.java:63)

                              [Server:server-two]    at org.uberfire.ext.metadata.backend.lucene.index.directory.DirectoryFactory.<init>(DirectoryFactory.java:54)

                              [Server:server-two]    at org.uberfire.ext.metadata.backend.lucene.LuceneConfigBuilder.build(LuceneConfigBuilder.java:109)

                              [Server:server-two]    at org.kie.workbench.drools.backend.server.LuceneConfigProducer.setup(LuceneConfigProducer.java:53)

                              [Server:server-two]    ... 60 more

                              [Server:server-two] Caused by: org.apache.lucene.store.LockObtainFailedException: Lock obtain timed out: NativeFSLock@/root/deepali/JBOSS/BRMS_22March/jboss-eap-6.4/.index/datasets/write.lock

                               

                              Let me attach the complete log for analysis.

                              • 12. Re: unable to deploy business-central.war on EAP in domain mode
                                ehugonnet Apprentice

                                You are deploying the same application on different servers on the same host thus you'll get conflicts as your application can't share resources. You will have to configure each application (aka deployment on each server) not to conflict with the other ones. it looks like also that you may have some filesystem right issues.