3 Replies Latest reply on Feb 18, 2016 7:58 AM by jimmy001

    HTTPS - Empty response

    jimmy001 Apprentice

      Hello,

       

      I am have deployed an application to wildfly 9.0.1. It contains a servlet which runs a database query which takes some time to return its results.

      When requesting the servlet via http everything is ok. But when using https the browser receives an empty response after 20 seconds.

      For testing purposes I have written a second query which returns a result after less than 1 second and in this case it works for when using https, too.

       

      Does anyone know the reason why this is happening and what I can do to prevent this ?

       

      J.

        • 1. Re: HTTPS - Empty response
          Martin Choma Expert

          Does playing with ssl-session-timeout attribute on undertow https-listener help?

          1 of 1 people found this helpful
          • 2. Re: HTTPS - Empty response
            jimmy001 Apprentice

            Hi,

             

            where can I set this property? I have changed the standalone, but it says, that the property is not supported:

             

            <subsystem xmlns="urn:jboss:domain:undertow:2.0">
                        <buffer-cache name="default"/>
                        <server name="default-server">
                            <http-listener name="default" socket-binding="http" redirect-socket="https"/>
                            <https-listener name="https" socket-binding="https" security-realm="UndertowRealm" read-timeout="200000" ssl-session-timeout="200000"/>
                            <host name="default-host" alias="localhost">
                                <location name="/" handler="welcome-content"/>
                                <filter-ref name="server-header"/>
                                <filter-ref name="x-powered-by-header"/>
                            </host>
                        </server>
                        <servlet-container name="default">
                            <jsp-config/>
                            <websockets/>
                        </servlet-container>
                        <handlers>
                            <file name="welcome-content" path="${jboss.home.dir}/welcome-content"/>
                        </handlers>
                        <filters>
                            <response-header name="server-header" header-name="Server" header-value="WildFly/9"/>
                            <response-header name="x-powered-by-header" header-name="X-Powered-By" header-value="Undertow/1"/>
                        </filters>
                    </subsystem>
            

                                                                                                                                                                                                                                                                                                                                          

            Message: WFLYCTL0376: Unexpected attribute 'ssl-session-timeout' encountered. Valid attributes are: 'socket-binding, worker, buffer-pool, enabled, resolve-peer-address, security-realm, verify-client, enabled-cipher-suites, enabled-protocols, enable-http2, enable-spdy, max-header-size, max-post-size, buffer-pipelined-data, max-parameters, max-headers, max-cookies, allow-encoded-slash, decode-url, url-charset, always-set-keep-alive, max-buffered-request-size, record-request-start-time, allow-equals-in-cookie-value, no-request-timeout, request-parse-timeout, tcp-backlog, receive-buffer, send-buffer, tcp-keep-alive, read-timeout, write-timeout'

            • 3. Re: HTTPS - Empty response
              jimmy001 Apprentice

              I increased the "read-timeout" and this helps.

              Thx for pushing me in the right direction.