8 Replies Latest reply on Feb 23, 2016 1:29 AM by Jamili Chewe

    Error in Starting Jboss 7

    Jamili Chewe Newbie

      Hi all,

      Am new developer  using jboss server, am trying to deploy alfresco in jboss 7 but when starting jboss I get the error below, can anyone help..

        JBoss Bootstrap Environment

       

        JBOSS_HOME: C:\jboss-as-7.1.1.Final

       

        JAVA: C:\Program Files\Java\jdk1.7.0_79\bin\java

       

        JAVA_OPTS: -XX:+TieredCompilation -Dprogram.name=standalone.bat -Xms64M -Xmx512M -XX:MaxPermSize=256M -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djboss.server.default.config=standalone.xml

       

      ===============================================================================

       

      12:38:07,359 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA

      12:38:07,628 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA

      12:38:07,692 INFO  [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final "Brontes" starting

      12:38:08,381 WARN  [org.jboss.as.threads] JBAS012400: The 'per-cpu' attribute is no longer supported. The value [10.000000] of the 'count' attribute is being combined with the value [20.000000] of the 'per-cpu' attribute and the current processor count [4] to derive a new value of [90] for 'count'.

      12:38:08,396 WARN  [org.jboss.as.threads] JBAS012400: The 'per-cpu' attribute is no longer supported. The value [10.000000] of the 'count' attribute is being combined with the value [20.000000] of the 'per-cpu' attribute and the current processor count [4] to derive a new value of [90] for 'count'.

      12:38:08,408 WARN  [org.jboss.as.threads] JBAS012400: The 'per-cpu' attribute is no longer supported. The value [10.000000] of the 'count' attribute is being combined with the value [20.000000] of the 'per-cpu' attribute and the current processor count [4] to derive a new value of [90] for 'count'.

      12:38:08,423 WARN  [org.jboss.as.threads] JBAS012400: The 'per-cpu' attribute is no longer supported. The value [10.000000] of the 'count' attribute is being combined with the value [20.000000] of the 'per-cpu' attribute and the current processor count [4] to derive a new value of [90] for 'count'.

      12:38:08,436 WARN  [org.jboss.as.threads] JBAS012400: The 'per-cpu' attribute is no longer supported. The value [10.000000] of the 'count' attribute is being combined with the value [20.000000] of the 'per-cpu' attribute and the current processor count [4] to derive a new value of [90] for 'count'.

      12:38:08,447 WARN  [org.jboss.as.threads] JBAS012400: The 'per-cpu' attribute is no longer supported. The value [10.000000] of the 'count' attribute is being combined with the value [20.000000] of the 'per-cpu' attribute and the current processor count [4] to derive a new value of [90] for 'count'.

      12:38:08,464 WARN  [org.jboss.as.jmx] JBAS011305: <jmx-connector/> is no longer supporting. <remoting-connector/> should be used instead to allow remote connections via JBoss Remoting.

      12:38:08,797 ERROR [org.jboss.as.controller.management-operation] Operation ("add") failed - address: ([

          ("subsystem" => "datasources"),

          ("data-source" => "AlfrescoDS")

      ]) - failure description: "JBAS014746: driver-name may not be null"

       

      My Standalone and module files are as attached.

      I appreciate your assit.

        • 1. Re: Error in Starting Jboss 7
          Jay SenSharma Master

          Looks like you are copying the "standalone.xml" file form your older  JBossAS 7.0  installation and then pasting it in the "JBoss AS 7.1.1" installation.  (Even though you can do that )

           

           

          Regarding WARNING message:

           

          12:38:08,464 WARN  [org.jboss.as.jmx] JBAS011305: <jmx-connector/> is no longer supporting. <remoting-connector/> should be used instead to allow remote connections via JBoss Remoting.
          

           

          Please see the default  "jmx" subsystem in JBoss AS 7.1.1 looks like following:

           

                  <subsystem xmlns="urn:jboss:domain:jmx:1.1">
                      <show-model value="true"/>
                      <remoting-connector/>
                  </subsystem>
          
          


          Where as your "jmx" subsystem looks older

           

                  <subsystem xmlns="urn:jboss:domain:jmx:1.0">
                      <jmx-connector registry-binding="jmx-connector-registry" server-binding="jmx-connector-server" />
                  </subsystem>
          
          


             Please fix them.   Also rather than manually editing the XML file ... it is always a best practice to use the jboss-cli or management utility like console for such editing from AS7 onwards.

           


          Regards

          Jay SenSharma

          • 2. Re: Error in Starting Jboss 7
            Jay SenSharma Master

            Previous comment just talk about WARNING messages (Ignorable)

             

            The Main Error is :

            12:38:08,797 ERROR [org.jboss.as.controller.management-operation] Operation ("add") failed - address: ([
                ("subsystem" => "datasources"),
                ("data-source" => "AlfrescoDS")
            ]) - failure description: "JBAS014746: driver-name may not be null"
            
            

             

            The error you are getting is because you are using a wrong driver name for your DataSource:

             

              <subsystem xmlns="urn:jboss:domain:datasources:1.0">
                 <datasources>
                       <datasource jta="true" jndi-name="java:jboss/datasources/AlfrescoDS"
                                            pool-name="AlfrescoDS" enabled="true" use-java-context="true" use-ccm="true">
                                   <connection-url>jdbc:mysql://localhost/alfresco</connection-url>
                                   <driver-class>com.mysql.jdbc.Driver</driver-class>  
                                   <!-- YOU Forgot 
                                       <driver>mysql</driver>
                                   -->
            

             

            As you are using module based driver hence you should be using the

              <subsystem xmlns="urn:jboss:domain:datasources:1.0">
                 <datasources>
                       <datasource jta="true" jndi-name="java:jboss/datasources/AlfrescoDS"
                                            pool-name="AlfrescoDS" enabled="true" use-java-context="true" use-ccm="true">
                                    <connection-url>jdbc:mysql://localhost/alfresco</connection-url>
                                    <driver>mysql</driver>     <!-- CORRECT  -->
            
            



            Reagrds

            Jay SenSharma

            • 3. Re: Error in Starting Jboss 7
              Jamili Chewe Newbie

              Hi @SenSharma,

              Thank you for your assist, I try to do as you suggest but am still get the same error.

              Please correct me from  below lines.

              14:00:48,733 WARN  [org.jboss.as.threads] JBAS012400: The 'per-cpu' attribute is no longer supported. The value [10.000000] of the 'count' attribute is being combined with the value [20.000000] of the 'per-cpu' attribute and the current processor count [4] to derive a new value of [90] for 'count'.

              14:00:49,073 ERROR [org.jboss.as.controller.management-operation] Operation ("add") failed - address: ([

                  ("subsystem" => "datasources"),

                  ("data-source" => "AlfrescoDS")

              ]) - failure description: "JBAS014746: driver-name may not be null"

              • 4. Re: Error in Starting Jboss 7
                Jay SenSharma Master

                Please attach your latest   standalone XML file.

                • 5. Re: Error in Starting Jboss 7
                  Jamili Chewe Newbie

                  Here is my standalone.xml

                   

                  <server xmlns="urn:jboss:domain:1.0">

                   

                      <extensions>

                          <extension module="org.jboss.as.clustering.infinispan"/>

                          <extension module="org.jboss.as.connector"/>

                          <extension module="org.jboss.as.deployment-scanner"/>

                          <extension module="org.jboss.as.ee"/>

                          <extension module="org.jboss.as.ejb3"/>

                          <extension module="org.jboss.as.jaxrs"/>

                          <extension module="org.jboss.as.jmx"/>

                          <extension module="org.jboss.as.jpa"/>

                          <extension module="org.jboss.as.logging"/>

                          <extension module="org.jboss.as.naming"/>

                          <extension module="org.jboss.as.osgi"/>

                          <extension module="org.jboss.as.remoting"/>

                          <extension module="org.jboss.as.sar"/>

                          <extension module="org.jboss.as.security"/>

                          <extension module="org.jboss.as.threads"/>

                          <extension module="org.jboss.as.transactions"/>

                          <extension module="org.jboss.as.web" />

                          <extension module="org.jboss.as.weld" />

                      </extensions>

                   

                      <management>

                          <security-realms>

                              <security-realm name="PropertiesMgmtSecurityRealm">

                                  <authentication>

                                      <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir" />

                                  </authentication>

                              </security-realm>

                          </security-realms>

                          <management-interfaces>

                             <native-interface interface="management" port="9999" />

                             <http-interface interface="management" port="9990"/>

                          </management-interfaces>

                      </management>

                         

                      <profile>

                          <subsystem xmlns="urn:jboss:domain:logging:1.0">

                              <console-handler name="CONSOLE">

                                  <level name="INFO"/>

                                  <formatter>

                                      <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                                  </formatter>

                              </console-handler>

                   

                              <periodic-rotating-file-handler name="FILE">

                                  <level name="INFO"/>

                                  <formatter>

                                      <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                                  </formatter>

                                  <file relative-to="jboss.server.log.dir" path="server.log"/>

                                  <suffix value=".yyyy-MM-dd"/>

                              </periodic-rotating-file-handler>

                   

                              <logger category="com.arjuna">

                                  <level name="WARN"/>

                              </logger>

                              <logger category="org.apache.tomcat.util.modeler">

                                  <level name="WARN"/>

                              </logger>

                              <logger category="sun.rmi">

                                  <level name="WARN"/>

                              </logger>

                   

                              <root-logger>

                                  <level name="INFO"/>

                                  <handlers>

                                      <handler name="CONSOLE"/>

                                      <handler name="FILE"/>

                                  </handlers>

                              </root-logger>

                          </subsystem>

                                  <subsystem xmlns="urn:jboss:domain:datasources:1.0">

                                  <datasources>

                                  <datasource jta="true" jndi-name="java:jboss/datasources/AlfrescoDS"

                                  pool-name="AlfrescoDS" enabled="true" use-java-context="true" use-ccm="true">

                                  <connection-url>jdbc:mysql://localhost/alfresco</connection-url>

                                  <driver-class>mysql</driver-class>

                                  <security>

                                  <user-name>root</user-name>

                                  <password></password>

                                  </security>

                                  </datasource>

                                  <drivers>

                                 

                                  <driver name="mysql" module="com.mysql.driver"/>

                                  </drivers>

                                  </datasources>

                                  </subsystem>

                  <!--       <subsystem xmlns="urn:jboss:domain:datasources:1.0">

                              <datasources>

                                  <datasource jndi-name="java:jboss/datasources/ExampleDS" enabled="true" use-java-context="true" pool-name="H2DS">

                                      <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1</connection-url>

                                      <driver>h2</driver>

                                      <pool></pool>

                                      <security>

                                          <user-name>sa</user-name>

                                          <password>sa</password>

                                      </security>

                                      <validation></validation>

                                      <timeout></timeout>

                                      <statement></statement>

                                  </datasource>

                                  <drivers>

                                      <driver name="h2" module="com.h2database.h2">

                                          <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>

                                      </driver>

                                  </drivers>

                              </datasources>

                          </subsystem> -->

                          <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.0">

                              <deployment-scanner scan-interval="5000" relative-to="jboss.server.base.dir" path="deployments" />

                          </subsystem>

                          <subsystem xmlns="urn:jboss:domain:ee:1.0" />

                          <subsystem xmlns="urn:jboss:domain:ejb3:1.0" />

                          <subsystem xmlns="urn:jboss:domain:infinispan:1.0" default-cache-container="hibernate">

                              <cache-container name="hibernate" default-cache="local-query">

                                  <local-cache name="entity">

                                      <eviction strategy="LRU" max-entries="10000"/>

                                      <expiration max-idle="100000"/>

                                  </local-cache>

                                  <local-cache name="local-query">

                                      <eviction strategy="LRU" max-entries="10000"/>

                                      <expiration max-idle="100000"/>

                                  </local-cache>

                                  <local-cache name="timestamps">

                                      <eviction strategy="NONE"/>

                                  </local-cache>

                              </cache-container>

                          </subsystem>

                          <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>

                          <subsystem xmlns="urn:jboss:domain:jca:1.0">

                              <archive-validation enabled="false" />

                              <bean-validation enabled="false" />

                              <default-workmanager>

                                  <short-running-threads blocking="true">

                                  <core-threads count="10" per-cpu="20"/>

                                          <queue-length count="10" per-cpu="20"/>

                                          <max-threads count="10" per-cpu="20"/>

                                          <keepalive-time time="10" unit="seconds"/>

                                  </short-running-threads>

                                  <long-running-threads blocking="true">

                                          <core-threads count="10" per-cpu="20"/>

                                          <queue-length count="10" per-cpu="20"/>

                                          <max-threads count="10" per-cpu="20"/>

                                          <keepalive-time time="10" unit="seconds"/>

                                  </long-running-threads>

                              </default-workmanager>

                          </subsystem>

                         

                         

                         

                         

                          <subsystem xmlns="urn:jboss:domain:jmx:1.1">

                   

                          <show-model value="true"/>

                   

                          <remoting-connector/>

                   

                          </subsystem>

                   

                         

                          <subsystem xmlns="urn:jboss:domain:jpa:1.0">

                              <jpa default-datasource=""/>

                          </subsystem>

                          <subsystem xmlns="urn:jboss:domain:naming:1.0" />

                          <subsystem xmlns="urn:jboss:domain:osgi:1.0" activation="lazy">

                              <configuration pid="org.apache.felix.webconsole.internal.servlet.OsgiManager">

                                  <property name="manager.root">jboss-osgi</property>

                              </configuration>

                              <properties>

                                  <!--

                                      A comma seperated list of module identifiers. Each system module

                                      is added as a dependency to the OSGi framework module. The packages

                                      from these system modules can be made visible as framework system packages.

                                      http://www.osgi.org/javadoc/r4v42/org/osgi/framework/Constants.html#FRAMEWORK_SYSTEMPACKAGES_EXTRA

                                  -->

                                  <property name="org.jboss.osgi.system.modules">

                                  org.apache.commons.logging,

                                  org.apache.log4j,

                                  org.jboss.as.osgi,

                                  org.slf4j,

                                  </property>

                                  <!--

                                      Framework environment property identifying extra packages which the system bundle

                                      must export from the current execution environment

                                  -->

                                  <property name="org.osgi.framework.system.packages.extra">

                                  org.apache.commons.logging;version=1.1.1,

                                  org.apache.log4j;version=1.2,

                                  org.jboss.as.osgi.service;version=7.0,

                                  org.jboss.osgi.deployment.interceptor;version=1.0,

                                  org.jboss.osgi.spi.capability;version=1.0,

                                  org.jboss.osgi.spi.util;version=1.0,

                                  org.jboss.osgi.testing;version=1.0,

                                  org.jboss.osgi.vfs;version=1.0,

                                  org.slf4j;version=1.5.10,

                                  </property>

                                  <!-- Specifies the beginning start level of the framework -->

                                  <property name="org.osgi.framework.startlevel.beginning">1</property>

                              </properties>

                              <modules>

                                  <!-- modules registered with the OSGi layer on startup -->

                                  <module identifier="javaee.api"/>

                                  <module identifier="org.jboss.logging"/>

                                  <!-- bundles installed on startup -->

                                  <module identifier="org.apache.aries.util"/>

                                  <module identifier="org.jboss.osgi.webconsole"/>

                                  <module identifier="org.osgi.compendium"/>

                                  <!-- bundles started in startlevel 1 -->

                                  <module identifier="org.apache.felix.log" startlevel="1"/>

                                  <module identifier="org.jboss.osgi.logging" startlevel="1"/>

                                  <module identifier="org.apache.felix.configadmin" startlevel="1"/>

                                  <module identifier="org.jboss.as.osgi.configadmin" startlevel="1"/>

                                  <!-- bundles started in startlevel 2 -->

                                  <module identifier="org.apache.aries.jmx" startlevel="2"/>

                                  <module identifier="org.apache.felix.eventadmin" startlevel="2"/>

                                  <module identifier="org.apache.felix.metatype" startlevel="2"/>

                                  <module identifier="org.apache.felix.scr" startlevel="2"/>

                                  <module identifier="org.apache.felix.webconsole" startlevel="2"/>

                                  <module identifier="org.jboss.osgi.jmx" startlevel="2"/>

                                  <module identifier="org.jboss.osgi.http" startlevel="2"/>

                                  <!-- bundles started in startlevel 3 -->

                                  <module identifier="org.jboss.osgi.blueprint" startlevel="3"/>

                                  <module identifier="org.jboss.osgi.webapp" startlevel="3"/>

                                  <module identifier="org.jboss.osgi.xerces" startlevel="3"/>

                              </modules>

                          </subsystem>

                          <subsystem xmlns="urn:jboss:domain:remoting:1.0"/>

                          <subsystem xmlns="urn:jboss:domain:resource-adapters:1.0" />

                          <subsystem xmlns="urn:jboss:domain:sar:1.0"/>

                          <subsystem xmlns="urn:jboss:domain:security:1.0">

                              <security-domains>

                                  <security-domain name="other" cache-type="default">

                                      <authentication>

                                          <login-module code="UsersRoles" flag="required"/>

                                      </authentication>

                                  </security-domain>

                              </security-domains>

                          </subsystem>

                          <subsystem xmlns="urn:jboss:domain:threads:1.0"/>

                          <subsystem xmlns="urn:jboss:domain:transactions:1.0">

                              <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>

                              <core-environment>

                                  <process-id>

                                      <uuid />

                                  </process-id>

                              </core-environment>

                              <coordinator-environment default-timeout="300"/>

                          </subsystem>

                          <subsystem xmlns="urn:jboss:domain:web:1.0" default-virtual-server="default-host">

                              <connector name="http" scheme="http" protocol="HTTP/1.1" socket-binding="http"/>

                              <virtual-server name="default-host" enable-welcome-root="true">

                                 <alias name="localhost" />

                                 <alias name="example.com" />

                              </virtual-server>

                          </subsystem>

                          <subsystem xmlns="urn:jboss:domain:weld:1.0" />

                      </profile>

                   

                      <interfaces>

                          <interface name="management">

                              <inet-address value="127.0.0.1"/>

                          </interface>

                          <interface name="public">

                             <inet-address value="127.0.0.1"/>

                          </interface>

                      </interfaces>

                   

                      <socket-binding-group name="standard-sockets" default-interface="public">

                          <socket-binding name="http" port="8080"/>

                          <socket-binding name="https" port="8443"/>

                          <socket-binding name="jmx-connector-registry" port="1090"/>

                          <socket-binding name="jmx-connector-server" port="1091"/>

                          <socket-binding name="jndi" port="1099"/>

                          <socket-binding name="osgi-http" port="8090"/>

                          <socket-binding name="remoting" port="4447"/>

                          <socket-binding name="txn-recovery-environment" port="4712"/>

                          <socket-binding name="txn-status-manager" port="4713"/>

                      </socket-binding-group>

                   

                  </server>

                  • 6. Re: Error in Starting Jboss 7
                    Jay SenSharma Master

                    Replace the following line in your DataSource:

                     

                    Replace

                                    <driver-class>mysql</driver-class>
                    


                    With

                                    <driver>mysql</driver>
                    


                    Regards

                    Jay SenSharma

                    • 7. Re: Error in Starting Jboss 7
                      Darran Lofthouse Master

                      One point not mentioned in this thread so far, JBoss AS 7 is now 3 major versions ago - the most recent release of the application server was WildFly 10.

                       

                      http://wildfly.org/downloads/

                      • 8. Re: Error in Starting Jboss 7
                        Jamili Chewe Newbie

                        HI all, It seems that something is still wrong, am still get

                         

                        09:23:38,755 INFO  [org.jboss.as.naming] (ServerService Thread Pool -- 38) JBAS011800: Activating Naming Subsystem

                        09:23:38,744 INFO  [org.jboss.as.webservices] (ServerService Thread Pool -- 48) JBAS015537: Activating WebServices Extension

                        09:23:39,247 INFO  [org.jboss.as.naming] (MSC service thread 1-1) JBAS011802: Starting Naming Service

                        09:23:39,254 INFO  [org.jboss.as.mail.extension] (MSC service thread 1-3) JBAS015400: Bound mail session [java:jboss/mail/Default]

                        09:23:39,445 INFO  [org.jboss.ws.common.management.AbstractServerConfig] (MSC service thread 1-5) JBoss Web Services - Stack CXF Server 4.0.2.GA

                        09:23:39,594 INFO  [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-8) Starting Coyote HTTP/1.1 on http--127.0.0.1-8080

                        09:23:39,822 INFO  [org.jboss.as.remoting] (MSC service thread 1-1) JBAS017100: Listening on /127.0.0.1:4447

                        09:23:39,825 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread 1-4) JBAS015012: Started FileSystemDeploymentService for directory C:\jboss-as-7.1.1.Final\standalone\deployments

                        09:23:39,822 INFO  [org.jboss.as.remoting] (MSC service thread 1-2) JBAS017100: Listening on /127.0.0.1:9999

                        09:23:40,165 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

                        JBAS014775:    New missing/unsatisfied dependencies:

                              service jboss.jdbc-driver.com_mysql (missing) dependents: [service jboss.data-source.java:/MySqlDS]