4 Replies Latest reply on Feb 24, 2016 2:46 AM by Panagiotis Chavariotis

    Jboss EAP 6.4 throwing org.jboss.modules.ModuleNotFoundException: org.jboss.as.jpa.openjpa:main

    Unice Gwe Mbuamuh Newbie

      Hi all,

       

      I am currently migrating an applictaion from Jboss EAP 6.0.1 to Jboss EAP 6.4. In the EAP 6.0.1, i used to bundle openjpa.jar and serp.jar into my application and it worked fine. When i migrated it failed with the following error "org.jboss.modules.ModuleNotFoundException: org.jboss.as.jpa.openjpa:main". I then created a module and deployed openjpa and serp libraries to it. And then adjusted my persistence.xml accordingly. But i still get the same error message in my server logs, and the deployment fails. Please find the module.xml. persistence.xml and server logs attached. Maybe someone can give me pointers as to where i am going wrong. I have double checked with the process followed in the below links; but it still didn't help. Thanks.

       

      JPA2 with OpenJPA 2.2.0 in JBossAS7.1.1 « JBoss

      OpenJPA in JBoss EAP 6.1