3 Replies Latest reply on Feb 29, 2016 11:16 PM by kiran g

    java.io.IOException: An established connection was aborted by the software in your host machine

    kiran g Newbie

      Above error is being logged every time some request is made to the server. Server.log is completely filled with below error messages. We are using Wildfly 9.0.0.Final version and Below is the full stack from where the error is being generated.

       

      02-22-2016 08:40:20.563 DEBUG [default I/O-3] [io.undertow.request.io] [] [] Error reading request: java.io.IOException: An established connection was aborted by the software in your host machine

        at sun.nio.ch.SocketDispatcher.read0(Native Method) [rt.jar:1.7.0_17]

        at sun.nio.ch.SocketDispatcher.read(Unknown Source) [rt.jar:1.7.0_17]

        at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source) [rt.jar:1.7.0_17]

        at sun.nio.ch.IOUtil.read(Unknown Source) [rt.jar:1.7.0_17]

        at sun.nio.ch.SocketChannelImpl.read(Unknown Source) [rt.jar:1.7.0_17]

        at org.xnio.nio.NioSocketConduit.read(NioSocketConduit.java:282) [xnio-nio-3.3.1.Final.jar:3.3.1.Final]

        at org.xnio.ssl.JsseSslConduitEngine.engineUnwrap(JsseSslConduitEngine.java:684) [xnio-api-3.3.1.Final.jar:3.3.1.Final]

        at org.xnio.ssl.JsseSslConduitEngine.unwrap(JsseSslConduitEngine.java:620) [xnio-api-3.3.1.Final.jar:3.3.1.Final]

        at org.xnio.ssl.JsseSslConduitEngine.unwrap(JsseSslConduitEngine.java:574) [xnio-api-3.3.1.Final.jar:3.3.1.Final]

        at org.xnio.ssl.JsseSslStreamSourceConduit.read(JsseSslStreamSourceConduit.java:89) [xnio-api-3.3.1.Final.jar:3.3.1.Final]

        at org.xnio.conduits.ConduitStreamSourceChannel.read(ConduitStreamSourceChannel.java:127) [xnio-api-3.3.1.Final.jar:3.3.1.Final]

        at io.undertow.server.protocol.http.HttpReadListener.handleEventWithNoRunningRequest(HttpReadListener.java:150)

        at io.undertow.server.protocol.http.HttpReadListener.handleEvent(HttpReadListener.java:128)

        at io.undertow.server.protocol.http.HttpReadListener.handleEvent(HttpReadListener.java:56)

        at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:92) [xnio-api-3.3.1.Final.jar:3.3.1.Final]

        at org.xnio.conduits.ReadReadyHandler$ChannelListenerHandler.readReady(ReadReadyHandler.java:66) [xnio-api-3.3.1.Final.jar:3.3.1.Final]

        at org.xnio.nio.NioSocketConduit.handleReady(NioSocketConduit.java:88) [xnio-nio-3.3.1.Final.jar:3.3.1.Final]

        at org.xnio.nio.WorkerThread.run(WorkerThread.java:539) [xnio-nio-3.3.1.Final.jar:3.3.1.Final]

       

      In the error reported stack, there is no trace of my native code, only undertow and xnio code is being reported. So it's becoming tough to debug for us. Any idea why this error is being reported? Do we have any property that needed to be added to application standalone.xml file avoid this error? Please provide any information that can resolve this issue.

       

       

      Thanks,

      Kiran G