0 Replies Latest reply on Mar 2, 2016 1:16 PM by Craig Setera

    Proper jboss-deployment-structure.xml to upgrade Jackson?

    Craig Setera Newbie

      I have a library that has a requirement for version 2.6 or greater of the Jackson library.  I've packaged the correct version in my WAR file and added a jboss-deployment-structure.xml to my WEB-INF, however I'm continuing to see resolution to the 2.5.1 version in Wildfly 9.0.2.  My XML file looks like the following:

       

      <?xml version="1.0" encoding="UTF-8"?>
      <jboss-deployment-structure>
          <deployment>
              <exclusions>
                  <module name="com.fasterxml.jackson.core.jackson-annotations"/>
                  <module name="com.fasterxml.jackson.core.jackson-core"/>
                  <module name="com.fasterxml.jackson.core.jackson-databind"/>
              </exclusions>
          </deployment>
      </jboss-deployment-structure>

       

      Can anyone suggest the proper XML file contents to pick up a newer packaged version of Jackson? Or, am I missing something else?

       

      Thanks!

      Craig