3 Replies Latest reply on Mar 10, 2016 6:41 PM by s.santilli

    Deploying a WAR file in JBoss WilfFly 10

    s.santilli Newbie

      Let me first start off by saying, that I am new to JBoss, and that I have researched deploying a war file into WildFly 10. Also, I do most of my development locally within eclipse, and deploy (again) locally from within eclipse (RunAs --> Run on Server). Doing it this way I have no problems, the application works fine.

       

      However, my question is this, if alternatively, I create the .war file, and deploy it into my WildFly server, that is by manually copy it and dropping the war into standalone/deployments folder ... it does not work the same.

       

      The deployment from within eclipse performs as I would expect it, but the manual deployment does not, its as if the are not configured equivalently. Perhaps I should apologize, but I guess I just though they would be.

       

      Additionally, I notice that, when deploying within eclipse, if I view my deployment within the admin console, there are significantly more parameters "auto-configured" if you will.

      Parameters such as, Content: { path, relative-to } etc ...

       

      What am I missing?  How do I make my manual deployment, operate (deploy) the same as when I deploy it via eclipse?

       

      Thank-you kindly

        • 1. Re: Deploying a WAR file in JBoss WilfFly 10
          Jay SenSharma Master

          You mentioned that "manually copy it and dropping the war into standalone/deployments folder ... it does not work the same."

           

          1. Can you please share the "server.log" to see what error cause the deployment to not to work?   

          OR

          2. Can you please elaborate more like what do you mean by "It does not work"?  Does it show any error (or do you see no entry n the log)i

           

          Also let us know how you are starting the standalone mode server? (this is just to verify if you are looking at the right directory or not?)

           

          Regards

          Jay SenSharma

          • 2. Re: Deploying a WAR file in JBoss WilfFly 10
            s.santilli Newbie

            Thanks for responding Jay,

             

            I've done my bets to answer below

            1. Can you please share the "server.log" to see what error cause the deployment to not to work?  

            - Allow me to clarify, deploying from within eclipse and manually (dropping .war inside standalone/deployment) both work .. just, they do not work the same. To clarify and elaborate further, when deploying my application from from within eclipse (Run-->Run On Server) and later reviewing the deployment via the Wildfly admin console (Deployments --> MyWar.war --> View), I notice I have the following parameters configured (please review screenshot below).

            deployment.PNG

            What I am desiring to do, is to have the manual deployment (.war file copied into standalone/deployments)  alone to configure the parameters listed above when it is deployed, so as to operate the equivalent as when I deploy directly from eclipse. How can I set these parameters when dropping a war file directly into WildFly?

             

            Thank-you kindly

            • 3. Re: Deploying a WAR file in JBoss WilfFly 10
              s.santilli Newbie

              Good DayJay,

               

              Yes this in a standalone JBoss Widfly server