1 Reply Latest reply on Mar 4, 2016 9:39 AM by Jasen Jacobsen

    Trouble deploying camel-rabbitmq bundle.

    Jasen Jacobsen Newbie

      I'd like to use the camel-rabbitmq component. I tried using Fuse's web console and command line to deploy it. It installs, but does not become active.

       

      JBossFuse:admin@root> install mvn:org.apache.camel/camel-rabbitmq/2.15.1.redhat-621084

       

      The OSGi management console shows:

      Imported Packages

       

      The following optional imports were not satisfied:

      com.rabbitmq.client

       

      javax.net.ssl

      org.apache.camel

      org.apache.camel.impl

      org.apache.camel.spi

      org.apache.camel.util

      org.apache.commons.pool

      org.apache.commons.pool.impl

      org.slf4j

       

      Shouldn't the camel-rabbitmq bundle pom handle those dependencies? And the management console shows that at least java.net.ssl is available, so why is that dependency not satisfied?

       

      Confused.

       

      I installed the camel-amqp module with no problems. It worked just as expected.

        • 1. Re: Trouble deploying camel-rabbitmq bundle.
          Jasen Jacobsen Newbie

          I believe I figured out the problem. I had to manually install and start the RabbitMQ client.

           

          JBossFuse:admin@root> install mvn:com.rabbitmq/amqp-client/3.3.4

           

          Once that was done, installing and starting the camel-rabbitmq bundle worked.

           

          This is confusing because I don't believe anywhere in the camel-rabbitmq install instructions it says you must first have the RabbitMQ provided client installed.