6 Replies Latest reply on Mar 10, 2016 8:55 AM by Ariel Carrera

    500 ActiveMQ-client-global-threads pool in Wildfly 10.0.0.Final

    Ariel Carrera Newbie

      Hi, i am migrating an application using Apache Camel, from Wildfly 8 / HornetQ to Wildfly 10 / Apache Artemis.

      When I run the application with Wildfly 10, I notice a strange behavior... wildfly/artemis creates about 500 threads of "ActiveMQ-client-global-threads".

      My "standalone-full.xml" configuration is:

       

       

                      <connection-factory name="InVmConnectionFactory" client-id="node1-xxx" entries="java:/ConnectionFactory" connectors="in-vm" />

                      <connection-factory name="RemoteConnectionFactory" client-id="node1-xxx" entries="java:jboss/exported/jms/RemoteConnectionFactory" connectors="http-connector"/>

                      <pooled-connection-factory name="activemq-ra" transaction="xa" client-id="node1-xxx" entries="java:/JmsXA java:jboss/DefaultJMSConnectionFactory" connectors="in-vm" />

       

       

      The application use the connection factories: "ConnectionFactory" and "JmsXA".

       

       

      I tried setting:

      use-global-pools="false"

      thread-pool-max-size="10"

       

       

      and:

      "max-pool-size"="10"

      "min-pool-size"="1"

       

       

      But it doesn't work.

       

       

      If I starts Wildfly 10.0.0.Final with the default configuration and without applications... the threads begin to be created slowly but never die (or reuses).

       

      Do you know if it is a an existent problem with the connection factory/client?