1 Reply Latest reply on Apr 19, 2018 6:37 AM by Carlo Marchiori

    Wildfly 9.0.2 service not getting stopped on Windows 2008 R2 64-bit Machine

    Mahboob Rizwan Shiak Newbie

      Hi,

       

      I have installed WildFly Full 9.0.2.Final on Windows server 2008 R2 Enterprise on 64-bit server. I have configured to be as a Windows Service and it does gets started up without any issues but when I am trying to stop the service, it doesn't get stopped and it throws gives following message in service log

       

      [2016-03-14 11:22:18] [error] [ 5396] Failed to stop 'Wildfly' service

      [2016-03-14 11:22:18] [error] [ 5396] The data area passed to a system call is too small.

      [2016-03-14 11:22:18] [error] [ 5396] Commons Daemon procrun failed with exit value: 6 (Failed to stop service)

      [2016-03-14 11:22:18] [error] [ 5396] The data area passed to a system call is too small.

       

       

      Wildfly details:-

      JBoss Modules version 1.4.3.Final

      JBoss MSC version 1.2.6.Final

      WildFly Full 9.0.2.Final

       

       

       

      I also configured it to be as Windows service account with a user and password as well as local account but neither of them seems to be working. I also tried all the workarounds available in following link "WildFly 8 service does not stop on Windows 2012 R2 core" but none of them seems to be working.

       

      Please help.

       

      Thanks in Advance.

        • 1. Re: Wildfly 9.0.2 service not getting stopped on Windows 2008 R2 64-bit Machine
          Carlo Marchiori Newbie

          Hi,

           

          tipically the message "The data area passed to a system call is too small" is desceptive, it just means there's another underlying error.

           

          Keep in mind that installing the service creates a key in the Window Registry (browseable with regedit) under

          HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Apache Software Foundation\Procrun 2.0\<server id>

           

          In particular under there there's a stop command like

          /c <jboss home>\bin\jboss-cli.bat --controller=localhost:9990 --connect  --command=:shutdown

           

          The stop port (9990) is fixed but if you have changed it in your standalone.xml you

          need to change the registry key as well by hand.

           

          Also, keep in mind that jboss-cli.bat uses the system variable JAVA_HOME.

          Make sure that the jdk under JAVA_HOME has a version compatible Wildfly's .class files.

           

          Best,

          Carlo.