2 Replies Latest reply on Mar 17, 2016 7:34 AM by Joseph Hance

    JBoss EAP 6.4 - Stopped Deploying UPDATED JSP files

    Joseph Hance Newbie

      I've run into an odd issue with JBoss EAP 6.4 on an Ubuntu Linux server with JDK 7.  Things were working fine for a couple of weeks since I installed JBoss and I've been doing some iterations of my app, a straight-up JavaEE app with JSP and Java servlets.  I've been deploying using the admin console.

       

      Here's what has started happening.  I redeploy (or undeploy and deploy) my .war file and it deploys without any errors.  But my JSP pages are never updated.  The server keeps serving up the old version of the JSP.  I've tried all manner of undeploy/redeploy, I tried copying the .war file to the deployment folder, I've tried stopping and restarting JBoss, none of those things help.

       

      The only solution I've found is to stop JBoss, delete the folder for my app under .../standalone/tmp/wor/jboss.web/default-host/<MY APP NAME>

       

      When I do that I see a java version of my jsp file (index.jsp) there jsp/index_jsp.java and then when I hit the page in my web browser the compile kicks in and I see an updated index_jsp.class file there as well.

       

      But if I don't delete that directory tree, the old JSP is there and it just sticks around.  I checked my server time and it was off by 10 minutes but I re-synched the time and that didn't change anything.

       

      I have a local copy of JBoss EAP 6.4 running on my Windows PC as a development instance and it's not having this problem there.  Also the strangest thing is that this just started happening yesterday.

       

      Thanks in advance for any suggestions.