0 Replies Latest reply on Apr 5, 2016 2:44 PM by Ray Englar

    Mission Control setup in EAP 6.4 creates log manager error

    Ray Englar Newbie

      I'm brand new to JBoss EAP. Just installed 6.4 and it comes up fine in standalone mode. I want to monitor remotely using Mission Control, which means adding the following java options:

       

      -Dcom.sun.management.jmxremote=true

      -Dcom.sun.management.jmxremote.port=7091

      -Dcom.sun.management.jmxremote.authenticate=false

       

      -Dcom.sun.management.jmxremote.ssl=false

      -XX:+UnlockCommercialFeatures

      -XX:+FlightRecorder

       

      Starting up with these options results in log manager errors:

      Caused by: java.lang.IllegalStateException: JBAS011592: The logging subsystem requires the log manager to be org.jboss.logmanager.LogManager. The subsystem has not be initialized and cannot be used. To use JBoss Log Manager you must add the system property "java.util.logging.manager" and set it to "org.jboss.logmanager.LogManager"

       

      So, I removed the Mission Control stuff, restarted, went into the console and added the system property, and now I have the following in standalone.xml:

       

      <system-properties>

              <property name="java.util.logging.manager" value="org.jboss.logmanager.LogManager"/>

          </system-properties>

       

      Put the java options back in, restarted, and still get the log manager error. Looked in this forum and somebody else had the same problem in WildFire, they added a new java option -Djava.util.logging.manager=org.jboss.logmanager.LogManager. I tried that too, same log manager error. Is there a third place that has to be changed?