4 Replies Latest reply on Apr 20, 2016 9:00 AM by Tomaz Cerar

    JBOSS EAP 6.4.5 is not suppoting JPA 2.1

    Kesava Kota Newbie

      I am using EAP 6.4.5 which comes with hibernate 4.2.18 version. I want to use hibernate 4.3.11-FINAL version which is JPA 2.1 compliant.

      But EAP 6.4.5 is JPA 2.0 compliant. Can you please suggest if there is a way i can override jboss JPA verion from the lib jars in my custom war.

      I have googled and tried various options and all are in vain.

      Appreciate your suggestion to acheive. Also would like to know using JPA 2.1 with EAP 6.4.5 is a good decision.

      Does it has anything to worry to counter/break app server functionality