0 Replies Latest reply on Apr 19, 2016 2:42 AM by sathish asokan

    'wmq.jmsra.rar' is not registered error

    sathish asokan Newbie

      I have cloned Jboss 5 and While starting a clone encountering the below error:

       

      Caused by: javax.management.InstanceNotFoundException: jboss.jca:service=RARDeployment,name='wmq.jmsra.rar' is not registered.

              at org.jboss.mx.server.registry.BasicMBeanRegistry.get(BasicMBeanRegistry.java:526)

              at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:662)

              at org.jboss.ejb3.JmxClientKernelAbstraction.invoke(JmxClientKernelAbstraction.java:58)

              at org.jboss.ejb3.mdb.inflow.JBossMessageEndpointFactory.createActivationSpec(JBossMessageEndpointFactory.java:322)

              ... 64 more

      2016-04-19 12:42:45,348 INFO  [org.jboss.system.server.profileservice.ProfileServiceBootstrap] (main) Loading profile: ProfileKey@a8e2b8[domain=default, server=default, name=SIMDHUBCL01]

      2016-04-19 12:42:45,349 ERROR [org.jboss.system.server.profileservice.ProfileServiceBootstrap] (main) Failed to load profile: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

       

       

      DEPLOYMENTS IN ERROR:

        Deployment "jboss.j2ee:ear=eopsinterface.ear,jar=eopsinterface.jar,name=KEOTTMDB,service=EJB3" is in error due to the following reason(s): javax.management.InstanceNotFoundException: jboss.jca:service=RARDeployment,name='wmq.jmsra.rar' is not registered.

        Deployment "vfszip:/opt/jboss-eap-5.0/jboss-as/server/SIMDHUBCL01/deploy/eopshubservice.ear/" is in error due to the following reason(s): java.lang.IllegalStateException: jboss.web.deployment:war=/eopshubservice is already installed.

        Deployment "jboss.j2ee:ear=eopsinterface.ear,jar=eopsinterface.jar,name=AEMDISQMDB,service=EJB3" is in error due to the following reason(s): javax.management.InstanceNotFoundException: jboss.jca:service=RARDeployment,name='wmq.jmsra.rar' is not registered.

       

       

      In the front end, only login page loading and after that any options clicked error 500 and backend error states the below

       

      2016-04-19 12:45:37,525 INFO  [STDOUT] (ajp-10.23.153.201-8409-2) Portlet map is empty. so fetching all portlets

      2016-04-19 12:46:04,323 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/eopshub]] (ajp-10.23.153.201-8409-3) StandardWrapper.Throwable

      java.lang.NullPointerException

              at eops.hub.controller.ControllerServlet.init(ControllerServlet.java:99)

              at javax.servlet.GenericServlet.init(GenericServlet.java:212)

              at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1048)

              at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:777)

              at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:129)

              at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)

              at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)

              at org.jboss.web.tomcat.service.session.ClusteredSessionValve.handleRequest(ClusteredSessionValve.java:135)

              at org.jboss.web.tomcat.service.session.ClusteredSessionValve.invoke(ClusteredSessionValve.java:94)

              at org.jboss.web.tomcat.service.session.LockingValve.invoke(LockingValve.java:62)

              at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)

              at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)

              at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)

              at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)

              at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)

              at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)

              at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)

              at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)

              at org.apache.coyote.ajp.AjpProcessor.process(AjpProcessor.java:436)

              at org.apache.coyote.ajp.AjpProtocol$AjpConnectionHandler.process(AjpProtocol.java:384)

              at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)

              at java.lang.Thread.run(Thread.java:619)

      2016-04-19 12:46:04,324 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/eopshub].[ControllerServlet]] (ajp-10.23.153.201-8409-3) Allocate exception for servlet ControllerServlet

      java.lang.NullPointerException

              at eops.hub.controller.ControllerServlet.init(ControllerServlet.java:99)

              at javax.servlet.GenericServlet.init(GenericServlet.java:212)

              at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1048)

              at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:777)

       

       

       

      Please help to fix this error.