2 Replies Latest reply on May 18, 2016 4:22 PM by Jaroslav Simak

    Error during deployment after http listener removed

    Jaroslav Simak Newbie

      Is it possible to completely remove http listener, when using web-services? I configured https listener and tried to remove http listener.

       

       

      I get "WFLYUT0063: Could not find the port number listening for protocol HTTP/1.1" during deployment of a web service.

       

       

      Caused by: java.lang.IllegalStateException: WFLYUT0063: Could not find the port number listening for protocol HTTP/1.1

              at org.wildfly.extension.undertow.WebServerService.getPort(WebServerService.java:68)

              at org.jboss.as.webservices.config.WebServerInfoImpl.getPort(WebServerInfoImpl.java:36)

       

       

      wildfly 10.0.0.Final

        • 1. Re: Error during deployment after http listener removed
          Tomaz Cerar Master

          that error would indicate that server is trying to find unsecure port for your webservice, but without complete stacktrace it is hard to say for sure.

           

          how does your undertow and web subsystem configuration look like?

          • 2. Re: Error during deployment after http listener removed
            Jaroslav Simak Newbie

            first, I added just

              <https-listener name="default-https" security-realm="SSLRealm" socket-binding="https"/>

            in undertow and removed the entry for https-listener. SSLRealm is defined as well. It seems OK for me.

             

             

            well, I actually found the problem

            I also added

             

                        <modify-wsdl-address>true</modify-wsdl-address>

                        <wsdl-secure-port>${my.https.port}</wsdl-secure-port>

             

            in webservices subsystem and than it works.

             

            But setting wsdl-secure-port is little bit irritating. The documentation says

             

            Set this property to explicitly define the HTTPS port that will be used for rewriting the SOAP address.

            Otherwise the HTTPS port will be identified by querying the list of installed HTTPS connectors.

             

            The webservice deployed has transport-guarantee set to CONFIDENTIAL in web.xml. There is only a https listener and no http listener in undertow.

            Regardless that, without setting wsdl-secure-port, wildfly tries to bind the webservice to http.

             

            Blame me, but it looks like a bug (either in the documentation or in the webservice subsystem)