0 Replies Latest reply on Jun 1, 2016 9:52 AM by Sreekanth Munarai

    Mod_jk configuration with JBoss7.1.1

    Sreekanth Munarai Master

      Hello Team,

       

      Unfortunately, i am facing issue with configuring JBoss with mod_jk/Apache.

      Have configured below changes, no idea where and what i am missing:

       

      Workers.properties:

      worker.list=Test

      worker.standaloneClone.port=8009

      worker.standaloneClone.host=IP

      worker.standaloneClone.type=ajp13


      uriworkermap:

      /*=Test

       

      mod_jk:

      JkWorkersFile conf/modjk/workers.properties

      JKLogFile logs/mod_jk1.log

      JkLogLevel info

      JkLogStampFormat "[%a %b %d %H:%M:%S %Y]"

      JkRequestLogFormat "%w %V %T"

       

      JkMount  /Calendar/* Test

       

      httpd.conf changes:

      LoadModule jk_module modules/mod_jk.so

       

      #mod_jk config

      Include conf/modjk/*.conf


      JBoss/standalone.xml changes:

      ------

      --

      <system-properties>

          <property name="jvmRoute" value="Test"/>

          <property name="useJK" value="true"/>

      </system-properties>

      ----------

      ----

      <connector name="ajp" protocol="AJP/1.3" scheme="http" socket-binding="ajp"/>

      ---

      ---

       

      No errors observed at apache.

       

      [Wed Jun 01 19:17:25 2016][4812:3436] [info] init_jk::mod_jk.c (3383): mod_jk/1.2.40 initialized

      [Wed Jun 01 19:17:26 2016][4812:3436] [info] init_jk::mod_jk.c (3383): mod_jk/1.2.40 initialized

       

      No errors at JBoss level, application deployed.

       

      Still m not able to access application thru Apache URL and Port.

       

      Please advise where m missing.

       

      Thanks,

      Sreeaknth