4 Replies Latest reply on Jun 17, 2016 10:42 AM by Barry LaFond

    Installing designer 10.0 into Eclipse or JBDS

    Dale Preston Newbie

      I'm trying to install Teiid Designer into Eclipse.  I've followed the instructions at Download & Install - JBoss Community.  I've also followed the instructions on that page trying to install Designer into JBDS.  On both platforms, following the instructions specific to each platform, I get an error that it can't find all the dependencies, specifically, DataTools Connectivity and RunTIme Clients.

       

      I remember seeing a forum post about an additional, not otherwise documented, source that has to be added in order to succeed in installing designer but I've tried for over an hour tonight to find it and I can't find that thread or the instructions.

       

      Can anyone provide the missing link for installing teiid designer 10.0 on Eclipse Mars or JBDS 9.0 or 9.1?

       

      Thanks,

       

      Dale

       

      THe error message is below:

       

      Cannot complete the install because one or more required items could not be found.

        Software being installed: Teiid Runtime Clients 10.0.0.Final-v20160413-1817-B4094 (org.teiid.designer.teiid.client.feature.feature.group 10.0.0.Final-v20160413-1817-B4094)

        Missing requirement: Teiid DataTools Connectivity 10.0.0.Final-v20160413-1817-B4094 (org.teiid.datatools.connectivity.feature.feature.group 10.0.0.Final-v20160413-1817-B4094) requires 'org.jboss.tools.locus.sf.saxon [9.5.1,10.0.0)' but it could not be found

        Cannot satisfy dependency:

          From: Teiid Runtime Clients 10.0.0.Final-v20160413-1817-B4094 (org.teiid.designer.teiid.client.feature.feature.group 10.0.0.Final-v20160413-1817-B4094)

          To: org.teiid.datatools.connectivity.feature.feature.group [10.0.0.Final-v20160413-1817-B4094]