2 Replies Latest reply on Sep 21, 2016 3:50 AM by Sony Joseph

    IBM MQ 8 and Fuse ESB 6.2.1 integration

    Sony Joseph Novice

      Hello,

       

      I am trying to integrate IBM MQ 8 with JBoss Fuse 6.2.1. I ahve osgi:install all OSGi bundles from IBM MQ package into the JBoss Fuse.

      While the route starts it gives a message that javax.jms.JMSRuntimeException not found by org.apache.geronim.specs.geronimo-jms_1.1.spec.

       

      I think this is due to the fact that the JBoss Fuse does not support JMS 2.0. ANy idea on how to get thru this.

       

      Sony

        • 1. Re: IBM MQ 8 and Fuse ESB 6.2.1 integration
          Hans-Juergen May Newbie

          The problem is: FUSE comes with  a JMS 1.1 provider bundle from Geronimo. And so does the IBM MQ allclientprereqs bundle. But the latter doesn't mainfest a OSGi Version for javax.jms. Geronimo manifests version 1.1.0

           

           

          My solution was, as far as i remember:

           

          features:install camel-jms

          #first: supply OSGi Version 1.1.0.1 for javax.jms (and others) while installing MQ prereqs bundle:

          osgi:install -s 'wrap:file:/opt/mqm/java/lib/OSGi/com.ibm.mq.osgi.allclientprereqs_8.0.0.3.jar$overwrite=merge&Export-Package=*; version=1.1.0.1'

          #then restart the container, so the newer MQ javax.jms will be used ifn favour of Geronimo 1.1.0

          #after restart, you can install the MQ client

          osgi:install -s file:/opt/mqm/java/lib/OSGi/com.ibm.mq.osgi.allclient_8.0.0.3.jar

          #and all should be working.

           

          Alternatively, you can uninstall the geronimo bundle befor installation of IBM MQ

          • 2. Re: IBM MQ 8 and Fuse ESB 6.2.1 integration
            Sony Joseph Novice

            Hello Hans

             

            Thank you very much for the answer. In my case it is the MQ client version 8.0.0.4 being used.

             

            In the similar lines as you have mentioned I added as  "osgi:install -s 'wrap:file:/opt/mqm/java/lib/OSGi/com.ibm.mq.osgi.allclientprereqs_8.0.0.3.jar$overwrite=merge&Export-Package=*; version=2.0.0'" -> the version 2.0.0 is used as the client bundle required 2.0.x and above.

             

            And finally it helped me.