1 Reply Latest reply on Jul 20, 2016 5:06 AM by Rustam Alimuradov

    mod_cluster 3.1 takes random port to connect to ajp

    Rustam Alimuradov Newbie

      Linux Mint 17, Apache/2.4.7 (Ubuntu), mod_cluster 1.3.1 x64, WildFly 8.2.1 and WidlFly 10.0.0.

      ajp connector configured in wildfly on port 8009, and it shows on mod_cluster-manager page:


      Node PC1 (ajp://192.168.0.24:8009)

      Balancer: mycluster,LBGroup: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 26,Ttl: 60000000,Status: NOTOK,Elected: 0,Read: 0,Transferred: 0,Connected: 0,Load: -1

       

      Apache logs:

      (111)Connection refused: AH00957: ajp: attempt to connect to 192.168.0.24:27233 (192.168.0.24) failed

      AH00959: ap_proxy_connect_backend disabling worker for (192.168.0.24) for 60s

      AH00940: ajp: disabled connection for (192.168.0.24)

      AH00940: ajp: disabled connection for (192.168.0.24)

      AH00940: ajp: disabled connection for (192.168.0.24)

      AH00940: ajp: disabled connection for (192.168.0.24)

      AH00940: ajp: disabled connection for (192.168.0.24)

       

      After manually changing ajp port to 27233 in standalone-full-ha.xml and restarting - status became OK.

       

      Why mod_cluster try to connect to not existing 27233? mod_cluster ignored port that it receives from WildFly and choose randomly from 27233, 11826, 14640.

       

      P.S. See also mod_cluster 1.3.1, apache 2.4 and wildfly 8/9 error