1 Reply Latest reply on Aug 26, 2016 3:33 PM by Suhas Wadadekar

    Upgrade modules in Wildfly..?

    Suhas Wadadekar Newbie

      After the latest Spring Framework 4.3 release, I decided to upgrade our application to it. One of the upgrade requirements was a minimum dependency bump to Jackson libraries to be 2.6+.


      I am using Wildfly 8.2.1, and the jackson module in this version is at 2.4.1 (2.5.1 for Wildfly 9 and 2.5.4 for Wildfly 10). I can compile my code using Jackson 2.6+, although I get runtime errors related to Jackson like NoSuchMethodError because the Jackson classes loaded are from the 2.4.1 jar because of implicit dependencies. I have tried to use jboss-deployment-structure.xml so I could prevent the implicit dependencies from being loaded first to no avail. I couldnt prevent the implicit dependencies from being loaded first and load the Jackson classes from the latest and greatest Jackson libraries packaged with the deployed application.


      The only thing that worked was, if I dropped the latest Jackson jars in the module directories and updated the module.xml to point to the latest jar.


      The question I have at this point is, how dangerous is it to upgrade the Wildfly modules on a as need basis? Is there a ceiling on the version of modules installed on Wildfly?