4 Replies Latest reply on Jul 26, 2016 3:23 PM by Dave Godbey

    Remove jaxws from Wildfly

    Dave Godbey Newbie

      Is there any documentation explaining how to remove jaxws from Wildfly? It seems rather tightly integrated to me, but I hope I'm wrong.

        • 1. Re: Remove jaxws from Wildfly
          Tomaz Cerar Master

          go into cli

          and type

           

          /subsystem=jaxws:remove

          reload

           

          and that should be it.

          • 2. Re: Remove jaxws from Wildfly
            Dave Godbey Newbie

            Tomaz,

            Thanks for that, easier to remove subsystems that way. I did that, but, it turns out that I seem to be missing classes from rt.jar. I thought I did this experiment before, but this time it worked! I moved rt.jar to my deployment WEB-INF/lib directory, and no longer had that problem.

             

            Obviously I don't want rt.jar in my app. Here's the error:

            13:58:38,201 ERROR [stderr] (Thread-136) Exception in thread "Thread-136" java.lang.NoClassDefFoundError: com/sun/xml/internal/ws/client/ClientTransportException

            13:58:38,198 INFO  [gov.nasa.hq.calendar.exchange.cron.CronTimerThread] (Thread-128) Thread iteration: 0 started.

            13:58:38,202 ERROR [stderr] (Thread-136)     at gov.nasa.hq.calendar.exchange.cron.CronTimerThread$JobThread.getEvents(CronTimerThread.java:122)

            13:58:38,207 ERROR [stderr] (Thread-136)     at gov.nasa.hq.calendar.exchange.cron.CronTimerThread$JobThread.run(CronTimerThread.java:115)

            13:58:38,211 ERROR [stderr] (Thread-136) Caused by: java.lang.ClassNotFoundException: com.sun.xml.internal.ws.client.ClientTransportException from [Module "deployment.hq_exchangeCron.ear.hq_exchangeCron.war:main" from Service Module Loader]

            13:58:38,213 ERROR [stderr] (Thread-136)     at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:198)

            13:58:38,214 ERROR [stderr] (Thread-136)     at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:363)

            13:58:38,215 ERROR [stderr] (Thread-136)     at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:351)

            13:58:38,219 ERROR [stderr] (Thread-136)     at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:93)

            13:58:38,225 ERROR [stderr] (Thread-136)     ... 2 more

             

            Here is my jboss-deployment-structure.xml contents:

            <jboss-deployment-structure>

            <!-- $Id: jboss-deployment-structure.xml 10920 2016-07-21 17:33:22Z dgodbey $ -->

              <ear-subdeployments-isolated>false</ear-subdeployments-isolated>

              <deployment>

                <dependencies>

                </dependencies>

              </deployment>

              <sub-deployment name="hq_exchangeCron.war">

                <dependencies>

                  <module name="javax.persistence.api" />

                  <module name="javax.wsdl4j.api" />

                  <module name="javax.xml.rpc.api" />

                  <module name="org.jboss.remote-naming" />

                  <module name="org.hibernate" />

                  <system export="true">

                      <paths>

                          <path name="com/sun/xml"/>

                      </paths>

                  </system>

                </dependencies>

              </sub-deployment>

            </jboss-deployment-structure>

             

             

            Added the system/paths/path=com/sun/xml, but that didn't change anything. I also tried com/sun/xml/*, but same result.

             

            I see there is also a sun/jdk module. What is best way to handle rt.jar dependencies?

            Thanks!

            • 3. Re: Remove jaxws from Wildfly
              Dave Godbey Newbie

              Never mind. I see that I need to use the full path, eg. com/sun/xml/internal/ws/client. Doesn't support hierarchy or wildcard.

              • 4. Re: Remove jaxws from Wildfly
                Dave Godbey Newbie

                I have everything under control. Only thing is I'd say is that this:

                bin/jboss-cli.sh --connect /subsystem=jaxrs:remove

                doesn't work because there is no subsystem by that name. Should be this:

                bin/jboss-cli.sh --connect /subsystem=webservices:remove

                or anything in the extensions list at the top of the standalone.xml (actually standalone-full.xml for me).

                 

                And I will say that just today have I come to the conclusion that what you did in the transition of JBoss 6.x to Wildfly (10 I'm using) with respect to classloading seems to be rock solid. I've been struggling for a while to understand it. I think I have finally figured it out. And I like it. Nicely done.

                 

                Thanks for responding to my questions!

                Dave