1 Reply Latest reply on Jul 29, 2016 9:38 AM by jaikiran pai

    Wildfly deployment

    khaled abu shamat Newbie

      I am using the latest version of wildflywhich is wildfly 10.0.0 final, and I am encountringa problem in deployment a folder which I am not facing when using wildfly 8, my problem is I have a web application folder and when I try to deploy it Iget this error message: "Deployment of '***.war' requested, but the deployment is not present." I am sure that I am following the right instructions to deploy my application as it was deployed using wildfly 8 but not wildfly 9 and 10.

       

      This is the instructions thatim following to deploy my application:

       

      1- Copy the web application folder to the standalone/deploymentsfolder,

      2- rename my folder toXXX.war.dodeploy,

      3- then go back tobin folderand run the standalone.bat file.

       

      But I get either nothing or a message saying Deployment of '***.war' requested, but the deployment is not present.

       

      Please Help,

      Kind regards,

      Khaled.

        • 1. Re: Wildfly deployment
          jaikiran pai Master

          khaled abu shamat wrote:

           


          This is the instructions thatim following to deploy my application:

           

          1- Copy the web application folder to the standalone/deploymentsfolder,

          2- rename my folder toXXX.war.dodeploy,

          3- then go back tobin folderand run the standalone.bat file.

           

           

          That's not the right set of instructions. I think you either misunderstood or skipped one step. What it should perhaps have been is:

           

          1. Copy the web application folder to the standalone/deployments folder

          2. Once the copy completes, create a separate new (empty) file called XXX.war.dodeploy - where XXX.war is the exact name of the folder that you copied

          3. Go back and start the server