1 Reply Latest reply on Apr 28, 2009 1:28 PM by Arbi Sookazian

    JBOSS reverse engineering not working

    admirer r Newbie

      JBOSS reverse engineering causes my system to hang.
      Database consists of some 100 tables for my Schema.
      The things I did.
      Created a Hibernate Project.
      Added hibernate configuratin file and then console configuration.
      And when I try to view my connection details in Hibernate views(From view Menu) Its showing Connection Factory and other details as null(Not showing anything).

      I tried using reverse mapping and it taking hours to fetch(Its hanging..)
      Is this some problem with JBOSS IDE 2.0(Beta)
      Or Some problem with my configurations.
      Any step by step guides to resolve this problem (JBOSS document).
      I tried every document and yet not found any solution.
      Help me solve this issue.

      If neded I will be posting the xml files in my next post

        • 1. Re: JBOSS reverse engineering not working
          Arbi Sookazian Master

          JBDS includes Hibernate tools. You are using hbm2java with HibernateToolTask to reverse engineer your db schema to entity classes and config/xml files.

          There should be a log that display the actions/errors.

          Try running the hbm2java directly from cmd line so you can see the errors.

          Other option is to create an Ant script that will do the same thing (use hbm2java to revengr your tables).

          Section 2.3 of JPA/Hibernate book covers this as well.