3 Replies Latest reply on Sep 11, 2016 5:36 PM by Adriano Schmidt

    Modcluster no WildFly 10 - outbound socket binding

    Adriano Schmidt Master

      Opa

       

      Galera... tô montando um loadbalancer com Apache HTTP Server e WildFly 10.1.... na Amazon... usando Ubuntu....

       

      Configurei o Standalone-full-ha.xml:


      <subsystem xmlns="urn:jboss:domain:modcluster:2.0">

           <mod-cluster-config advertise-socket="modcluster" proxies="<IP INTERNO APACHE>:80" advertise="false" sticky-session="true" load-balancing-group="arquitetura" connector="ajp">

         <dynamic-load-provider>

           <load-metric type="cpu"/>

         </dynamic-load-provider>

           </mod-cluster-config>

       

      </subsystem>

       

       

       

      Mas deu o erro:

       

      2016-08-23 14:39:23,713 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) WFLYCTL0013: Operation ("add") failed - address: ([("subsystem" => "modcluster")]) - failure description: {

          "WFLYCTL0412: Required services that are not installed:" => ["jboss.outbound-socket-binding.\"<IP INTERNO DO APACHE>:80\""],

          "WFLYCTL0180: Services with missing/unavailable dependencies" => ["jboss.modcluster is missing [jboss.outbound-socket-binding.\"IP INTERNO DO APACHE:80\"]"]

      }

      2016-08-23 14:39:23,764 INFO  [org.jboss.as.controller] (Controller Boot Thread) WFLYCTL0183: Service status report

      WFLYCTL0184:    New missing/unsatisfied dependencies:

            service jboss.outbound-socket-binding."IP INTERNO DO APACHE:80" (missing) dependents: [service jboss.modcluster]

       

       

       

      O que será q pode ser?

       

       

      Abraço!
      Adriano Schmidt

      www.localhost8080.com.br

        • 1. Re: Modcluster no WildFly 10
          Adriano Schmidt Master

          achei o problema...

           

          até o WildFly 8 se usava um

           

          proxy-list="<IP INTERNO APACHE>:80"

           

          agora é não existe mais o atributo proxy-list, agora é proxies, mas se você usar assim:

           

          proxies="<IP INTERNO APACHE>:80"


          acontece o erro q aconteceu pra mim....

           

          então você tem que usar assim:


          proxies="apache1"


          e dentro do seu socket-binding-group, você deve colocar isso:


          <outbound-socket-binding name="apache1">

            <remote-destination host="<IP INTERNO DO APACHE>" port="80"/>

          </outbound-socket-binding>

           

          assim, vai funcionar, ou pelo menos dar outro erro.... vou abrir outro chamado agora

           

          Valeu galera!

           

          Adriano Schmidt

          www.localhost8080.com.br

          • 2. Re: Modcluster no WildFly 10 - outbound socket binding
            Marcelo Sales Newbie

            Fala Adriano, blz?

             

            Cara, você conseguiu fazer funcionar o mod_cluster com máquina remota? Tenho funcionando em nas versões. 7,8,8.2 e 9. Atualizei a pouco para o 10.1 com apache 2.4.23. Não consigo registrar no mod_cluster o host remoto. Nos logs do domain master aparece pra mim que o host foi registrado mas não lista no mod_cluster_manager.

            Quando eu registro servers no host do domain ai ele aparece sem problemas no painel do cluster_manager.

            Já se deparou com este problema?

            • 3. Re: Modcluster no WildFly 10 - outbound socket binding
              Adriano Schmidt Master

              opa... consegui sim essa semana quero postar um artigo com um passo-a-passo...

               

               

              mas não entendi quando que funcionou ou não... pode explicar melhor?