1 Reply Latest reply on Sep 4, 2016 9:24 AM by jaikiran pai

    How to enable http redirect to https in jboss eap 6.4

    grivasan rajan Newbie

      Hi All,

      redirecting http to https  is working in jboss 7 but with same configuration its not working in EAP 6.4. Is any one comment on this.

       

      the problem found is  when "http-executor"  thread pool added, is not supported it seems. its not parsing the configuration. server boot up failing with Configuration parse parse error.

      ==============================================================

       

       

      Example Stand alone:-

      =====================

       

      <subsystem xmlns="urn:jboss:domain:threads:1.1">

        <blocking-bounded-queue-thread-pool name="http-executor">

        <core-threads count="200"/>

        <queue-length count="100"/>

        <max-threads count="2048"/>

        <keepalive-time time="60" unit="seconds"/>

        </blocking-bounded-queue-thread-pool>

        </subsystem>

       

      Redirect port in connector

      ===================

      <subsystem xmlns="urn:jboss:domain:web:1.1" default-virtual-server="default-host" native="false">

        <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"    redirect port="8443" executer="http-executor"/>

       

       

        <connector name="https" scheme="https" protocol="HTTP/1.1" socket-binding="https" enable-lookups="false" secure="true">

        <ssl name="foo-ssl" password="secret" protocol="TLSv1" key-alias="foo" certificate-key-file="../standalone/configuration/foo.keystore" />

        </connector>

       

       

        <virtual-server name="default-host" enable-welcome-root="true">

        <alias name="localhost"/>

        <alias name="example.com"/>

        </virtual-server>

        </subsystem>

       

       

      and below under socket-binding

      =========================

       

      <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

        <socket-binding name="http" port="8080"/>

        <socket-binding name="https" port="8443"/>

        <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>

        <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

        <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>

        <socket-binding name="osgi-http" interface="management" port="8090"/>

        <socket-binding name="remoting" port="4447"/>

        <socket-binding name="txn-recovery-environment" port="4712"/>

        <socket-binding name="txn-status-manager" port="4713"/>

        <outbound-socket-binding name="mail-smtp">

        <remote-destination host="localhost" port="25"/>

        </outbound-socket-binding>

        </socket-binding-group>

      </server>