3 Replies Latest reply on Sep 14, 2016 1:21 AM by J Prasanna Venkatesan

    JBoss CLI - CJK Character Issue

    J Prasanna Venkatesan Newbie

      Dear All,

       

      Environment:

       

      CentOS Linux release 7.1.1503 (Core)

      /usr/java/jdk1.8.0_45/

      WildFly 8.2.0

      I am executing few LoginModule commands using file. My file name is command.cli

      Its content is

       

      [root@cu490 temp]# cat command.cli

      /subsystem=security/security-domain=SourceForge/authentication=classic/login-module=org.jboss.security.auth.spi.LdapExtLoginModule3:add(code=org.jboss.security.auth.spi.LdapExtLoginModule, flag=sufficient, module-options={ "java.naming.provider.url" => "ldap://a.com:389/", "java.naming.referral" => "follow", "java.naming.factory.initial" => "com.sun.jndi.ldap.LdapCtxFactory", "java.naming.security.authentication" => "simple", "bindDN" => "cn=in00655,OU=비임직원,OU=SK이노베이션,DC=test,DC=net", "bindCredential" => "xxxxxx", "baseCtxDN" => "ou=SK이노베이션,DC=test,DC=net", "baseFilter" => "(sAMAccountName={0})", "roleAttributeID" => "memberOf", "roleAttributeIsDN" => "true", "rolesCtxDN" => "DC=test,DC=net", "roleFilter" => "(member={1})", "roleRecursion" => "1", "searchTimeLimit" => "5000", "searchScope" => "SUBTREE_SCOPE", "allowEmptyPasswords" => "false", "throwValidateError" => "true" }){allow-resource-service-restart=true}

       

      [root@cu490 temp]# /opt/collabnet/teamforge/runtime/jboss/bin/jboss-cli.sh --connect --file=command.cli

      {

          "outcome" => "success",

          "response-headers" => {"process-state" => "reload-required"}

      }

      [root@cu490 temp]# vim /opt/collabnet/teamforge//runtime/jboss/standalone/configuration/standalone-full.xml

       

      Content inside standalone-full.xml is

       

      <login-module name="org.jboss.security.auth.spi.LdapExtLoginModule3" code="org.jboss.security.auth.spi.LdapExtLoginModule" flag="sufficient">

                                  <module-option name="java.naming.provider.url" value="ldap://a.com:389/"/>

                                  <module-option name="java.naming.referral" value="follow"/>

                                  <module-option name="java.naming.factory.initial" value="com.sun.jndi.ldap.LdapCtxFactory"/>

                                  <module-option name="java.naming.security.authentication" value="simple"/>

                                  <module-option name="bindDN" value="cn=in00655,OU=????,OU=SK?????,DC=test,DC=net"/>

                                  <module-option name="bindCredential" value="xxxxxx"/>

                                  <module-option name="baseCtxDN" value="ou=SK?????,DC=test,DC=net"/>

                                  <module-option name="baseFilter" value="(sAMAccountName={0})"/>

                                  <module-option name="roleAttributeID" value="memberOf"/>

                                  <module-option name="roleAttributeIsDN" value="true"/>

                                  <module-option name="rolesCtxDN" value="DC=test,DC=net"/>

                                  <module-option name="roleFilter" value="(member={1})"/>

                                  <module-option name="roleRecursion" value="1"/>

                                  <module-option name="searchTimeLimit" value="5000"/>

                                  <module-option name="searchScope" value="SUBTREE_SCOPE"/>

                                  <module-option name="allowEmptyPasswords" value="false"/>

                                  <module-option name="throwValidateError" value="true"/>

                              </login-module>

       

      You can see instead of CJK characters we are seeing ??? in standalone-full.xml

       

      Please throw some light on this.

       

      Thanks & Regards,

      J Prasanna Venkatesan