3 Replies Latest reply on Sep 28, 2016 10:25 AM by Madhu Chitti

    Running JBoss Fuse 6.2 Server failing

    Madhu Chitti Newbie

      Hi

       

      JDK Version -- 1.8.0_101

      JBoss Developer Studio Version: 9.1.0.GA

      JBoss Fuse Version -- jboss-fuse-6.2.0.redhat-133

       

      I am trying to run JBoss Fuse 6.2 Server from JBoss Developer Studio  , but it is failing with below error. I am getting the same error while running the start.bat from command prompt.

       

      77% [=======================================================>                ]ERROR: Bundle org.apache.karaf.admin.management [14] Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.management/2.4.0.redhat-620133 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.admin))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.admin)

      78% [========================================================>               ]

        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)

        at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)

        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)

        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)

        at java.lang.Thread.run(Thread.java:745)

       

       

      79% [========================================================>               ]

      80% [=========================================================>              ]

      81% [==========================================================>             ]

      82% [===========================================================>            ]

      83% [===========================================================>            ]

      84% [============================================================>           ]

      85% [=============================================================>          ]

      86% [=============================================================>          ]

      87% [==============================================================>         ]

      88% [===============================================================>        ]

      89% [================================================================>       ]ERROR: Bundle io.fabric8.support.support-karaf [197] Error starting mvn:io.fabric8.support/support-karaf/1.2.0.redhat-133 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.support.support-karaf [197]: Unable to resolve 197.0: missing requirement [197.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.scr)(version>=1.8.0)(!(version>=2.0.0))))

      org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.support.support-karaf [197]: Unable to resolve 197.0: missing requirement [197.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.scr)(version>=1.8.0)(!(version>=2.0.0)))

        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)

        at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)

        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)

        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)

        at java.lang.Thread.run(Thread.java:745)

       

       

      90% [================================================================>       ]ERROR: Bundle io.fabric8.support.support-fabric8 [200] Error starting mvn:io.fabric8.support/support-fabric8/1.2.0.redhat-133 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.support.support-fabric8 [200]: Unable to resolve 200.0: missing requirement [200.0] osgi.wiring.package; (osgi.wiring.package=io.fabric8.api))

      org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.support.support-fabric8 [200]: Unable to resolve 200.0: missing requirement [200.0] osgi.wiring.package; (osgi.wiring.package=io.fabric8.api)

        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)

        at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)

        at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)

        at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)

        at java.lang.Thread.run(Thread.java:745)

       

       

      91% [=================================================================>      ]

       

      Thanks

        • 1. Re: Running JBoss Fuse 6.2 Server failing
          Madhu Chitti Newbie

          Hi

           

          I tried using the JBoss Developer Studio Version : 8.1.0.GA and ran JBoss Fuse 6.2 Server with version jboss-fuse-6.2.0.redhat-133 and getting the below error. Any help will be appreciated.

           

          ---------------------------------

          77% [=======================================================>                ]ERROR: Bundle org.apache.karaf.admin.management [14] Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.management/2.4.0.redhat-620133 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.admin))

          org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management [14]: Unable to resolve 14.0: missing requirement [14.0] osgi.wiring.package; (osgi.wiring.package=org.apache.karaf.admin)

           

           

          78% [========================================================>               ] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)

            at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)

            at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)

            at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)

            at java.lang.Thread.run(Thread.java:745)

           

           

          79% [========================================================>               ]

          80% [=========================================================>              ]

          81% [==========================================================>             ]

          82% [===========================================================>            ]

          83% [===========================================================>            ]

          84% [============================================================>           ]

          85% [=============================================================>          ]

          86% [=============================================================>          ]

          87% [==============================================================>         ]

          88% [===============================================================>        ]

          89% [================================================================>       ]ERROR: Bundle io.fabric8.support.support-karaf [197] Error starting mvn:io.fabric8.support/support-karaf/1.2.0.redhat-133 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.support.support-karaf [197]: Unable to resolve 197.0: missing requirement [197.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.scr)(version>=1.8.0)(!(version>=2.0.0))))

          org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.support.support-karaf [197]: Unable to resolve 197.0: missing requirement [197.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.scr)(version>=1.8.0)(!(version>=2.0.0)))

            at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)

            at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)

            at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)

            at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)

            at java.lang.Thread.run(Thread.java:745)

           

           

          90% [================================================================>       ]ERROR: Bundle io.fabric8.support.support-fabric8 [200] Error starting mvn:io.fabric8.support/support-fabric8/1.2.0.redhat-133 (org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.support.support-fabric8 [200]: Unable to resolve 200.0: missing requirement [200.0] osgi.wiring.package; (osgi.wiring.package=io.fabric8.api))

          org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.support.support-fabric8 [200]: Unable to resolve 200.0: missing requirement [200.0] osgi.wiring.package; (osgi.wiring.package=io.fabric8.api)

            at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)

            at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)

            at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)

            at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)

            at java.lang.Thread.run(Thread.java:745)

           

           

          91% [=================================================================>      ]

          ---------------------------------

          JDK Version -- 1.8.0_101

          JBoss Developer Studio Version: 9.1.0.GA

          JBoss Fuse Version -- jboss-fuse-6.2.0.redhat-133

           

          I followed the steps provided in the link JBoss Fuse - Get Started | 'Red Hat Developers'

           

          Thanks,

          Madhu

          • 2. Re: Running JBoss Fuse 6.2 Server failing
            Grzegorz Grzybek Novice

            Hello

             

            "missing requirement [200.0] osgi.wiring.package; (osgi.wiring.package=io.fabric8.api)" means fabric-api bundle wasn't started. 6.2.0.redhat-133 distribution contains this bundle, because it is critical one.

            Same for org.apache.karaf.admin.core -> org.apache.karaf.admin.management dependency.

             

            Are you sure the distribution is unpacked correctly?

             

            regards

            Grzegorz Grzybek

            • 3. Re: Running JBoss Fuse 6.2 Server failing
              Madhu Chitti Newbie

              Thanks Grzegorz. You are right, there is a issue in unpacking the distribution jar. While extracting the below jars where not getting extracted.

              This is because of the McAfee restriction, it is not allowing to create the folder structure with “.scr”

              Thanks for your help.