8 Replies Latest reply on Jan 19, 2017 9:59 AM by Matthew Phillips

    Red Hat Container Development Kit installation fails without details

    Martin Van Velsen Newbie

      I've been trying to install the Red Hat Development Suite for hours now and no matter what I try the Red Hat Container Development Kit

      fails to install without giving me any indication as to what went wrong. It just says "failed" as can be seen in the screenshot below.

       

      - Red Hat Development Suite 1.1.0-GA

      - Red Hat Container Development Kit 2.2.0.GA

      - The installer is executed in elevated/admin mode

      - Any previous instances of Vagrant and VirtualBox have been removed

      - Windows 7

       

      Regards,

       

      Martin

       

      SDK-Fail.png

        • 1. Re: Red Hat Container Development Kit installation fails without details
          rhopp Newbie

          Hi Martin,

          In the installation directory should be file install.log which should tell us more. Would you post it here, please?

          Radim

          • 2. Re: Red Hat Container Development Kit installation fails without details
            Jeremy Grimm Newbie

            Hi Martin.

             

            I ran into the same issue today.  In the log file (C:\DevelopmentSuite\install.log), I found the following error.  I'm not sure what this error is telling me though, so I'm kind of dead in the water too.

             

            I'm running on Windows 7 (64-bit).

             

             

             

            Tue, 27 Sep 2016 20:39:04 GMT-ERROR: cdk - Error: Command failed: vagrant plugin install "c:\DevelopmentSuite\cdk\plugins\vagrant-sshfs-1.2.0.gem"

            C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:439:in `resolve_for_zero': Unable to resolve dependency: 'vagrant-sshfs (= 1.2.0)' requires 'win32-process (>= 0)' (Gem::UnsatisfiableDependencyError)

              from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:350:in `resolve_for'

              from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:196:in `resolve'

              from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/request_set.rb:358:in `resolve'

              from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/dependency_installer.rb:473:in `resolve_dependencies'

              from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/dependency_installer.rb:373:in `install'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:129:in `block in install_local'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:284:in `block in with_isolated_gem'

              from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/user_interaction.rb:45:in `use_ui'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:283:in `with_isolated_gem'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:126:in `install_local'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/plugin/manager.rb:47:in `install_plugin'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/action/install_gem.rb:37:in `call'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/warden.rb:34:in `call'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/builder.rb:116:in `call'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/runner.rb:66:in `block in run'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/util/busy.rb:19:in `busy'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/runner.rb:66:in `run'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/base.rb:14:in `action'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:32:in `block in execute'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:31:in `each'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:31:in `execute'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/root.rb:56:in `execute'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/cli.rb:42:in `execute'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/environment.rb:302:in `cli'

              from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/bin/vagrant:174:in `<main>'

             

             

            Manually running the vagrant plugin install "c:\DevelopmentSuite\cdk\plugins\vagrant-sshfs-1.2.0.gem" command generates the same error.

            • 3. Re: Red Hat Container Development Kit installation fails without details
              Martin Van Velsen Newbie

              After a bunch more sleuthing I finally figured out what was going on. It looks like the installer doesn't play well with the windows environment and it doesn't analyze the path variable to determine what components are already installed. I already had vagrant and virtualbox installed but after I uninstalled those I was still left with various remnants on my system, as is usually the case on Windows. After I tried to install the SDK I noticed that my path environment variable had been updated but the old path was still there. To fix this I had to:

               

              1. Uninstall vagrant, cygwin and virtualbox

              2. Remove any environment variables pointing to my vagrant bin, cygwin bin and virtualbox bin directories. This is especially important for cygwin because it looks like the Redhat installer doesn't properly detect an existing installation if it wasn't installed in the default directory and even then it has trouble

              3. Remove any path variables set by the Redhat SDK installer

              4. Remove any traces of my old vagrant installation by removing C:\users\<username>.vagrant.d

              5. Remove any traces of my old virtualbox installation by removing C:\users\<username>.VirtualBox

              6. Manually install the version of vagrant and virtualbox indicated by the installer

              7. Add the bin paths for vagrant and virtual box back to your environment if you want to be able to run those tools from the command line

              8. Start the Redhat SDK installer in elevated/administrator mode

              9. Unselect the virtualbox and vagrant packages but let the installer take care of the cygwin installation. From what I can tell it's not easy to have it use your existing cygwin

              10. Follow the installation instructions as per usual from the official documentation page

               

              This worked for me.

              • 4. Re: Red Hat Container Development Kit installation fails without details
                Jeremy Grimm Newbie

                Thanks Martin.

                 

                After following your list of to-do's, I ended up with a different dependency issue.

                 

                Fri, 30 Sep 2016 14:35:18 GMT-ERROR: cdk - Error: Command failed: vagrant plugin install "c:\DevelopmentSuite\cdk\plugins\vagrant-service-manager-1.3.3.gem"

                C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:439:in `resolve_for_zero': Unable to resolve dependency: 'vagrant-service-manager (= 1.3.3)' requires 'rubyzip (~> 1.2.0)' (Gem::UnsatisfiableDependencyError)

                  from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:350:in `resolve_for'

                  from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:196:in `resolve'

                  from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/request_set.rb:358:in `resolve'

                  from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/dependency_installer.rb:473:in `resolve_dependencies'

                  from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/dependency_installer.rb:373:in `install'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:129:in `block in install_local'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:284:in `block in with_isolated_gem'

                  from C:/DevelopmentSuite/vagrant/embedded/lib/ruby/2.2.0/rubygems/user_interaction.rb:45:in `use_ui'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:283:in `with_isolated_gem'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:126:in `install_local'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/plugin/manager.rb:47:in `install_plugin'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/action/install_gem.rb:37:in `call'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/warden.rb:34:in `call'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/builder.rb:116:in `call'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/runner.rb:66:in `block in run'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/util/busy.rb:19:in `busy'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/runner.rb:66:in `run'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/base.rb:14:in `action'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:32:in `block in execute'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:31:in `each'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:31:in `execute'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/root.rb:56:in `execute'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/cli.rb:42:in `execute'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/environment.rb:302:in `cli'

                  from C:/DevelopmentSuite/vagrant/embedded/gems/gems/vagrant-1.8.1/bin/vagrant:174:in `<main>'

                 

                 

                I'll dig into this.

                • 5. Re: Red Hat Container Development Kit installation fails without details
                  Guy Davis Newbie

                  Hi Jeremy,


                  Did you find any solution to the ruby dependency error?  I'm failing with a very similar error:

                   

                  Thu, 03 Nov 2016 04:03:25 GMT-ERROR: cdk - Error: Command failed: vagrant plugin install "c:\DevelopmentSuite\cdk\plugins\vagrant-registration-1.3.0.gem"

                  C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.6/lib/vagrant/pre-rubygems.rb:31:in `exec': No such file or directory - ruby (Errno::ENOENT)

                    from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.6/lib/vagrant/pre-rubygems.rb:31:in `<main>'

                   

                  Any tips would be appreciated.

                  • 6. Re: Red Hat Container Development Kit installation fails without details
                    Matthew Phillips Newbie

                    I too cannot get the development kit to complete. The error in the log which seems to be relevant is:

                     

                    Tue, 13 Dec 2016 09:19:18 GMT-ERROR: cdk failed to install: Error: Command failed: vagrant plugin install "C:\RedHat\DevelopmentSuite\cdk\plugins\vagrant-sshfs-1.2.0.gem"
                    [0;31mBundler, the underlying system Vagrant uses to install plugins,
                    reported an error. The error is shown below. These errors are usually
                    caused by misconfigured plugin installations or transient network
                    issues. The error from Bundler is:

                    Unable to resolve dependency: 'vagrant-sshfs (> 0)' requires 'win32-process (>= 0)' [0m

                     

                    What with your poor error messages on your installer, this, and even the links to the newer installer not working I have now been trying and failing to install this tool for over a month.

                    If this presages the rest of my experience with RedHat I am very much unimpressed. Tools are so far useless. Support is so far very poor.

                    • 7. Re: Red Hat Container Development Kit installation fails without details
                      Matthew Phillips Newbie

                      After uninstalling by hand, re-installing vagrant by hand, then trying to install the dev kit I get the same error as Jeremy Grimm above

                       

                      Tue, 13 Dec 2016 10:42:07 GMT-ERROR: cdk failed to install: Error: Command failed: vagrant plugin install "C:\RedHat\DevelopmentSuite\cdk\plugins\vagrant-service-manager-1.3.3.gem"

                      C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:439:in `resolve_for_zero': Unable to resolve dependency: 'vagrant-service-manager (= 1.3.3)' requires 'rubyzip (~> 1.2.0)' (Gem::UnsatisfiableDependencyError)

                      from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:350:in `resolve_for'

                      from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/resolver.rb:196:in `resolve'

                      from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/request_set.rb:358:in `resolve'

                      from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/dependency_installer.rb:473:in `resolve_dependencies'

                      from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/dependency_installer.rb:373:in `install'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:129:in `block in install_local'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:284:in `block in with_isolated_gem'

                      from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/user_interaction.rb:45:in `use_ui'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:283:in `with_isolated_gem'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/bundler.rb:126:in `install_local'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/plugin/manager.rb:47:in `install_plugin'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/action/install_gem.rb:37:in `call'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/warden.rb:34:in `call'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/builder.rb:116:in `call'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/runner.rb:66:in `block in run'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/util/busy.rb:19:in `busy'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/action/runner.rb:66:in `run'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/base.rb:14:in `action'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:32:in `block in execute'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:31:in `each'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/install.rb:31:in `execute'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/plugins/commands/plugin/command/root.rb:56:in `execute'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/cli.rb:42:in `execute'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/lib/vagrant/environment.rb:302:in `cli'

                      from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.8.1/bin/vagrant:174:in `<main>'

                      • 8. Re: Red Hat Container Development Kit installation fails without details
                        Matthew Phillips Newbie

                        It turned out our corporate proxy was interfering with the SSL certificate handshake.

                        Getting our IT to put in an exception has, I think, fixed it. But maybe it was something else.