0 Replies Latest reply on Oct 17, 2016 9:38 AM by vinod boppanna

    jbpm 6.1 Persistence Task table actualOwner field null

    vinod boppanna Newbie

      I am using jbpm 6.1 for leave application work flow.

       

      Please find attached persistence.xml, applicationContext.xml and leaveApplicationCancellation.bpmn2 files.

       

      I am using the following code to start the session and to start the process.

       

                  KnowledgeBuilder kbuilder = KnowledgeBuilderFactory.newKnowledgeBuilder();

                  kbuilder.add(ResourceFactory.newUrlResource("file:///opt/jboss-7.1/jboss-as-7.1.0.Final/standalone/deployments/test.war/WEB-INF/classes/bpmnresource/aaiis/establishment/leave/leaveApplicationCancellation.bpmn2"),

                          ResourceType.BPMN2);            

                  KieBase kbase = kbuilder.newKnowledgeBase();

                  EntityManagerFactory emf = Persistence.createEntityManagerFactory("aaiisPersistence");

                  RuntimeEnvironment environment = RuntimeEnvironmentBuilder.Factory.get()

                      .newDefaultBuilder()

                      .knowledgeBase(kbase)

                      .entityManagerFactory(emf)

                      .persistence(true)

                      .get();

                  RuntimeManager manager = RuntimeManagerFactory.Factory.get().newSingletonRuntimeManager(environment);

                  RuntimeEngine engine = manager.getRuntimeEngine(null);

                  this.jpaSession = engine.getKieSession();

                  this.localTaskService = (InternalTaskService) engine.getTaskService();

       

      I am starting the process with the following code

       

      final ProcessInstance processInstance = jpaSession.startProcess(processName, parameters);

       

      processName = leaveApplicationCancellation.bpmn2

      process Parameters are {userList=[15110, 9869], others=22186, transactionId=24161, employee=22186}

       

      But in the "Task" table, the columns "taskInitiator" and "actualOwner" are getting filled with NULL values.

      Also, only one entry is being made in the Task table (three entries should have been made ..one for "employee" and one each in "userList").

      Please help me in solving this.

       

      Thanks & Regards