0 Replies Latest reply on Oct 18, 2016 8:12 AM by Zoltán Balogh

    package exposed via two dependency chains.

    Zoltán Balogh Newbie

      Hi!

       

      We have been working in  jboss-fuse-6.2.1.redhat-084 with camel version 2.15.1.

      I need use camel-protobuf 2.15.1 (uses protobuf-java 2.6.1) in the route to transform messages meanwhile the proto messages are compiled with protobuf-java 3.0.

      The bundle manifest includes :

      Import-Package: org.apache.camel.dataformat.protobuf;version=" 2.15.0.3", com.google.protobuf;version="[3.0.0,3.1.0)"......

       

      In this case I have got the following error message:

       

      Uses constraint violation. Unable to resolve resource esb-route [esb-route/4.0.0] because it is exposed to package 'com.google.protobuf' from resources com.google.protobuf [com.google.protobuf/3.0.0] and com.google.protobuf [com.google.protobuf/2.6.1] via two dependency chains.

      Chain 1:

        esb-route [esb-route/4.0.0]

          import: (&(osgi.wiring.package=com.google.protobuf)(version>=3.0.0)(!(version>=3.1.0)))

           |

          export: osgi.wiring.package: com.google.protobuf

        com.google.protobuf [com.google.protobuf/3.0.0]

      Chain 2:

        esb-route [esb-route/4.0.0]

          import: (&(osgi.wiring.package=org.apache.camel.dataformat.protobuf)(version>=2.15.0)(!(version>=3.0.0)))

           |

          export: osgi.wiring.package=org.apache.camel.dataformat.protobuf; uses:=com.google.protobuf

        org.apache.camel.camel-protobuf [org.apache.camel.camel-protobuf/2.15.1.redhat-621084]

          import: (&(osgi.wiring.package=com.google.protobuf)(version>=2.6.0)(!(version>=3.0.0)))

           |

          export: osgi.wiring.package: com.google.protobuf

        com.google.protobuf [com.google.protobuf/2.6.1]

       

      How can configure my bundle that the imported camel-protobuf doesn't use the protobuf-java 2.6.0 but 3.0?

       

      Thx your help!

       

      Regards,

      Topicfun