1 Reply Latest reply on Oct 19, 2016 5:29 AM by Tristan Tarrant

    Enabling JMX

    Arash Bijanzadeh Newbie

      Trying to enable jmx for infinispan installation, I followed the documentation and reached to this host.xml configuration file. Unfortunatily I still cannot connect to the jmx port remotely.

       

      <subsystem xmlns="urn:jboss:domain:jmx:1.3">
        
      <remoting-connector use-management-endpoint="false"/>
        
      <expose-resolved-model/>
        
      <expose-expression-model/>
        
      </subsystem>
        
      <subsystem xmlns="urn:jboss:domain:naming:2.0">
        
      <remote-naming/>
        
      </subsystem>
        
      <subsystem xmlns="urn:jboss:domain:remoting:3.0">
        
      <!--<endpoint/>-->
        
      <!--<http-connector name="http-remoting-connector" connector-ref="default" security-realm="ApplicationRealm"/>-->
        
      <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>
        
      </subsystem>
        
      <subsystem xmlns="urn:jboss:domain:security:1.2">
        
      <security-domains>
        
      <security-domain name="other" cache-type="default">
        
      <authentication>
        
      <login-module code="Remoting" flag="optional">
        
      <module-option name="password-stacking" value="useFirstPass"/>
        
      </login-module>
        
      <login-module code="RealmDirect" flag="required">
        
      <module-option name="password-stacking" value="useFirstPass"/>
        
      </login-module>
        
      </authentication>
        
      </security-domain>
        
      <security-domain name="jboss-web-policy" cache-type="default">
        
      <authorization>
        
      <policy-module code="Delegating" flag="required"/>
        
      </authorization>
        
      </security-domain>
        
      <security-domain name="jboss-ejb-policy" cache-type="default">
        
      <authorization>
        
      <policy-module code="Delegating" flag="required"/>
        
      </authorization>
        
      </security-domain>
        
      <security-domain name="jaspitest" cache-type="default">
        
      <authentication-jaspi>
        
      <login-module-stack name="dummy">
        
      <login-module code="Dummy" flag="optional"/>
        
      </login-module-stack>
        
      <auth-module code="Dummy"/>
        
      </authentication-jaspi>
        
      </security-domain>
        
      </security-domains>
        
      </subsystem>
        
      <subsystem xmlns="urn:jboss:domain:security-manager:1.0">
        
      <deployment-permissions>
        
      <maximum-set>
        
      <permission class="java.security.AllPermission"/>
        
      </maximum-set>
        
      </deployment-permissions>
        
      </subsystem>
        
      <subsystem xmlns="urn:jboss:domain:transactions:3.0">
        
      <core-environment>
        
      <process-id>
        
      <uuid/>
        
      </process-id>
        
      </core-environment>
        
      <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
        
      </subsystem>
      </profile>

      </profiles>